How do you delete com ports in XP?

Discussion in 'Windows Desktop Systems' started by SrfGeK, Apr 22, 2003.

  1. SrfGeK

    SrfGeK Guest

    Need some help in deleting com ports in XP. To make a long story short we are using a plotting program that reads data from a GPS through a 9 pin serial plug.
    We are using a Belkin serial to USB adapter on a Toshiba laptop with XP Pro. We load the driver in for the Belkin adapter and get it to work once. If we stop the plotting program and restart we lose the com port data and have to reload the driver. Xp assign's a new com port each time we reload the driver. We now have com's 1,3,4,5,6,7 assigned to what ever that is not in use.
    How do I remove these com ports so I can reuse them? I need com's 1 & 2.

    They do not show up in Device Manager. Only the one that is currently in use.

    There are no services assigned to these com ports that I can find to shut off.
    All I need is a way to remove the com ports. Any ideas?
    :confused:
     
  2. GoNz0

    GoNz0 NTFS Stoner

    Messages:
    2,781
    Location:
    the year 2525
    XP has a habit of doing that. on win 98 you could boot into safe mode and they would all show up in there. XP dont seem to do that. if there is a fault with the driver, they may all still show up as active. try safe mode but i dint think it will work.
     
  3. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Removing the adapter might get rid of them.
     
  4. SrfGeK

    SrfGeK Guest

    Thanks for the reply's but it didn't work. There must be a way to delete the com ports of you are going to run out of them. We are going to use system restore to see if that works. :(
    I'll let you know
     
  5. zyfos

    zyfos Resurrected

    Messages:
    236
    In device manager, did you try
    View -> Show hidden devices
     
  6. SrfGeK

    SrfGeK Guest

    Tried Restore but it didn't work. When I get to work tomorrow I'll try the hidden devices. Thanks for the help so far. Any other ideas?
     
  7. Trinity

    Trinity Guest

    You might check in the bios, serial ports may have different settings. Generally you have two serial ports and you can choose the address for it 2f8... or whatever, I think you have four choices or automatic or disable. You might mess around with these settings if it's on automatic try setting it to a static address or maybe even disable altogether if you're using a USB from serial connector.