Home Network - Username and Password

Discussion in 'Windows Desktop Systems' started by johnnycat, Feb 22, 2006.

  1. johnnycat

    johnnycat OSNN One Post Wonder

    Messages:
    4
    Hello,

    I have 3 computers on a network (all connected to a router). Computers A and C are running XP Pro. Computer B is running XP Home.

    Computer A can access B and C (simply by viewing the workgroup computers and selecting it) . However, when I try to go from B to A i am prompted for a username and password. I have had this network set up for some time now, and never before did I receive this prompt.

    The only thing I added on computer A was a new account (for a total of 2) and passwords for each account.

    Computer B, when booting up, does not go through the welcome screen, rather it just goes right to the desktop.

    Now, what I DO NOT want to do is set up the same user accounts on Computer B. I do not want a login of any type. As long as a computer is behind my firewall, access should be granted to the shared folders.

    Any help is greatly appreciated. Thanks so much.
     
  2. Mastershakes

    Mastershakes Moderator

    Messages:
    1,721
    Location:
    Montreal
    Syntax when entering the username should be the following

    ComputerName\Username

    i.e my comp's name is JOHNNYCASH

    When I wish to connect to it, at the prompt I put in

    JOHNNYCASH\Shakes and my password
     
  3. johnnycat

    johnnycat OSNN One Post Wonder

    Messages:
    4
    Thanks for the quick response.

    But I do not want to be prompted for a logon. Is it possible for it to just connect (like it used to (and like how A goes to B and A goes to C))? Also, what caused this sudden change?

    Thanks.
     
  4. johnnycat

    johnnycat OSNN One Post Wonder

    Messages:
    4
    Follow up to your post:

    Is username shakes on both computers? Does the password have to be the same on both computers?

    Is there any alternative way to set up a network so no logon is necessary?

    Again, my network WAS working. All computers were able to access the other. Now I have a logon prompt.

    I should also note, while trying to figure this out -

    When I enable simple file sharing, I do not receive a logon prompt, I just get the message it is unavailable. (Previously when this was working I used simple file sharing.)

    With simple file sharing disabled, I get the logon prompt.

    Thanks
     
    Last edited: Feb 22, 2006
  5. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    You do not have to set up the user accounts on the XP Home machine, CP Home has crippled networking capabilities and does all network authentication via the Guest account. Since you have an XP Home machine, you cant really do network access limitations, you have to enable simple file sharing on the XP Pro machines. You also have to modify a security policy on the XP Pro machines: http://www.j79zlr.com/howto.php?id=14
     
  6. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    When you added a second account to A it became necessary for B to figure out what account you really want to access on A. Thus you now have a network access prompt when trying to access A from B. It can't connect as it used to because it no longer knows which part of A to talk to until it prompts you.

    A can go directly because there is only one account each on B and C.
     
  7. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Since B is running XP Home it does not authenticate with the user account in use, it uses the guest account, that is the limitation of "simple" file sharing. It is idiotic.
     
  8. johnnycat

    johnnycat OSNN One Post Wonder

    Messages:
    4
    Well, here is where I got with it. I don't think I will ever get it to work "ideally".

    I created a NEW username on A and the same NEW username on B. I left both with no passwords. I then went to Administrative Tools -> Local Security Policy -> Local Policies -> Security Options. I then Disabled "Accounts: Limit local account use of blank passwords to console logon only". Then I went to Administrative Tools -> Local Security Policy -> Local Policies -> User Rights Assignment. I then added the group "Everyone" to "Access this computer from the network". I also disabled simple file sharing.

    With this config, when logged on as the NEW user on B, access is granted without a logon box.

    Note: I have the same primary username (PRIMARY) on both computers. A is password protected, B is not.

    If I leave simple file sharing disabled (above config) on Pro (A), then when logged on as PRIMARY on B I receieve the logon box and can do either:

    1.) Type in the NEW username, with no password.
    2.) Use username COMPUTER-A\PRIMARY and the password for PRIMARY on A.

    IF I enable simple file sharing on Pro, then I cannot access A when logged on computer B with username PRIMARY. (I just receieve the message "A is not available")

    If it were to work "ideally", regardless of who you are logged on B as, you should be able to access A with no logon. (i.e. how it would work with simple file sharing enabled). Creating an extra username on A with no password would not be necessary.

    Is there anything I haven't explored or any other settings left to try?

    Thanks for everyones help.
     
  9. Mastershakes

    Mastershakes Moderator

    Messages:
    1,721
    Location:
    Montreal
    Agreed. Looks like you've found a good workaround, I can't think of anything you've missed.
     
  10. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Try this, enable simple filesharing. Remove the same accounts on the pro machine. Go Start>Run> secpol.msc

    Click Local Policies>Security options
    Look for Network access: Let everyone permissions apply to Anonymous users
    Double click (or properties) and click enable.

    Try that, if it doesnt work try enabling the guest account.