Help Wanted

Discussion in 'Windows Desktop Systems' started by Rescueone, Feb 23, 2002.

  1. Rescueone

    Rescueone Guest

    HI Can someone please help me with this problem on XP. when I start the computer it comes up with a report that the"devldr32.exe has performed an illegal function" and has to be shut down. Then you have a choice to "send" or "don't send" a report. I've tried both send and don't sent but it doesn't make any difference the box closes but as soon as I open up any program it's back with the same thing and I can't press it fast enough it just keeps popping up, sometimes 20-30 times as a program is starting.

    I've tried looking in msconfig and the startup in program files but it's not there.
    I can see it when I ctrl, alt, delete. I then close down the two files but it dosen't make any differance the next program I open its there again.
    Any Idea's on how to solve this problem would be gratefull driving me MAD
    Thanks in Advance
  2. This may sound a bit obvious but, I have done a quick search on my HD for file of same name and it does not seem to exist. Have you tried deleting devldr32.exe file?
  3. zman

    zman Guest

    That file is to do with Soundblaster Live, go and update to the latest driver @

    If that doesnt work then do this :

    You'll need to replace the file called DEVLDR32.EXE with the version that comes on your the Windows XP CD, in i386/Drivers.Cab. Expand the cab Find DEVLDR32.EXE and copy it.

    Then boot into Safe mode (Press F8 at startup). Run the Task Manager (CTRL+ALT+DEL) and make sure DEVLDR32.EXE isn't running; if it is select it and click End Task. Then copy the DEVLDR32.EXE file you extracted earlier to your Windows/System32 folder and replace the Creative labs version.
  4. Rescueone

    Rescueone Guest

    Thanks to you Both that should work it is on my hard drive as a hidden file .
    So now I know its sound blaster thats the problem I'll sort it now and let you know the result
    Thanks again :D
  5. Rescueone

    Rescueone Guest

    Just Like to say thank you that worked a treat :D
    It's what this forum is very good at sorting Problems like that.
    Thanks again from A very happy XP user :D :D
  6. gothic

    gothic LinuXPert

    Cornwall Nr. England
    zman I cannot thank you enough, I've had that self same problem on and off for ages, and knew that it was Soundblaster related, but all I did was to re-install a known "Good" Image. Could illucidate further, but to what end??