Has anyone else had problems with the CD/DVD drive not clearing after a cd is removed

Discussion in 'General Hardware' started by LPDad, Mar 4, 2002.

  1. LPDad

    LPDad OSNN Addict

    I have ex-perienced :D this with several XP machines, and I wondered if any of you had the same problem. (and if you have had this problem how do you solve it)

    after you remove a cd/dvd from your drive the information about the last disk is not cleared and remains, even when you place a new disk in the drive.
    for example:
    When I have the serious sam disk in drive E and I look at the information under my computer I can see:
    drive c

    drive e (serSamVxx)

    drive a

    now when I eject or remove the serious sam disk and put another disk(different disk) in the drive and go to my computer and look at the listed drives the SeriousSam info still shows up under drive e. I have noticed this happening on 3 different machines, all of which are running XP pro. (I do not have autoplay enabled, and even if I do play a subequent CD the old info remains)
    Is this a problem (bug) with XP ????

    I have tried various means to get rid of the old cd listing and update to the new cd-- sometimes it changes and sometimes it does not.

    Any ideas on this???

    How many of you have experienced this???
    :confused: :confused: :confused: :confused:
  2. MrBadidea

    MrBadidea Guest

    Aye, I noticed that happening a lot recently too - only way to remedey it is to restart.

    I noticed that it happend on WinME and 2K (Pro & Advanced Server) too tho :(
  3. Deszaras

    Deszaras Guest

    I had that happen at first too, I think it has something to do with XP's autoplay. I disabled autoplay on the autoplay menu, and then ENabled it using TweakUI and never had the problem again.
  4. SkidMark

    SkidMark Guest

    Yeah , i've had it happen too ... damn annoying !

    One way around it seems to be ..if you right click on the drive in explorer and select "eject" ....wait for the drive to change "icon refreshes" ... then close the tray again , this usually works for me

    toggling autoplay settiings does have an effect on this , but not in any sensible sort of way ...

    i also found if your using tweakXP , DON'T select the "disable autoplay in that program ... it seems to cause the prob for me ..
    instead use tweakui or disable it using gpedit.msc

    hope this helps:)