guest account on 2k and shares, help

Discussion in 'Windows Desktop Systems' started by bytezboy, Jul 24, 2003.

  1. bytezboy

    bytezboy Guest

    I am having trouble accessing shares from a 2K and XP machine. The computer with the shares is running Win2k SP3, guest account is enabled. I shared all my drives with GUEST access, checked the boxes named full control, change and read under the Allow column. Now, when I try to access the shares, it says the following:

    "\\computername\drive is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

    Access denied."

    I don't get why it's not working, it used to work back then.. it's so frustrating, the only way I can make the shares accessible is to set permissions to "Everyone". Much appreciated for any help.
  2. j79zlr

    j79zlr Glaanies script monkey Political User

    First off, this is really not the best way to control shares. You should leave the default share permissions set the way they are, and restrict access with NTFS security permissions. Second, you need to have passwords on accounts to access them with XP.

    You have a gigantic security risk with sharing entire drives as Guest. I do not recommend you doing this.

    Any administrator can access the drives because all drives are administrative shares. They are hidden, if you are logged on as an administrator, you can access them by manually typing in Run or Explorer:
    and so on.

    disable simple file sharing on XP and set up your shares correctly.
  3. bytezboy

    bytezboy Guest

    I use a router and there are only 3 computers on the network, I am not worried about security.. I just want to control every drive as if it's on one computer, don't see why guest access is such a risk. It used to work fine..

    What do you mean by NTFS security permissions? Could you elaborate more on that and how I configure it?

    There is no simple file sharing on XP, i'm using the Home Edition. Also, i'm not sharing from the XP computer.