Graphic/ACPI woes

Discussion in 'Graphics Cards' started by Funkyb, Jun 5, 2003.

  1. Funkyb

    Funkyb Simple

    Messages:
    82
    Location:
    Melbourne, York
    System specs, AMD1200, 512Mb RAM, MSI nvidia GeForce FX5600, 12x DVD, Creative Audigy 1, Window XP Home.
    I have a problem with my NVIDIA Graphics card (GeForce FX5600 128MB AGP). I use the TV out lead to watch my DVDs with and every so often the TV screen flicks very quickly to show my desktop and then back to the film. I upgraded to this card because Creative didn’t support my DXR3 decoder in windows XP :( .
    After a quick chat in the forum on the MSI Web page I got the impression that the card would be better off running on its own IRQ. I had a look at my IRQ settings and all my PCI devices and my AGP card run through IRQ11. The simple thing would be to change the IRQ of my graphics card but with windows XP that aint so simple. All the options to change the settings in Device Manager are greyed out. I read somewhere in NTFS.org that to change it you must change the ACPI computer to Standard Computer in device manager. I did this and after all hell broke loose re-installing devices, only my Graphics card and my firewire card that came with Creative Audigy were on the same IRQ.
    This created a new problem, when I shut the computer down I got the “It is safe to turn off your pc”:confused: screen, which I never had before. Again I looked this up in NTFS and I found that this could be resolved in device manager - hidden devices. I ‘should see the NT ATM / Legacy Interface mode with a red cross on it. Double click it and on the screen that appears at the bottom choose enable from the drop down menu.’ But I didn’t see the NT/ATM/Legacy thingy. I re-installed ACPI and I could switch off my computer but all my PCI devices were on IRQ 11 again.
    .

    ….
    HELP!
    If you can make any sense of that, you must know the answer!!!
     
  2. Taurus

    Taurus hardware monkey

    Messages:
    3,206
    Location:
    Sacramento, CA
    i understood every word... but haven't any sort of answer for ya. :(

    two things, though...

    1- making your computer a non-acpi compliant pc (standard computer) takes away the ability for the pc to shut itself off. i don't think you can make it non-acpi and have it shut off.

    2- many-a-people here say irq sharing shouldn't cause any problems. xp does a pretty decent job of managing them. i would look elsewhere to solve your problem.

    about how often does the screen do that during a movie? is it a steady 5 or 10 minutes in between? you made sure to disable your screensaver and 'turn off monitor' time, right?
     
  3. Funkyb

    Funkyb Simple

    Messages:
    82
    Location:
    Melbourne, York
    1. Thanks for the info
    2. There is no set pattern to it, I have watched a film where it did not happen at all and the next time I watched the same film, 5 times in the space of a minute. And what is 'turn of monitor' time?
     
  4. Funkyb

    Funkyb Simple

    Messages:
    82
    Location:
    Melbourne, York
    Duh, Monitor off time, I got it now, silly me :eek:
     
  5. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    This is information on PCI Steering, which is probably the ACPI feature which is causeing you problems.
    The most common piece of advice for AGP cards it to leave the adjacent PCI slot empty to reduce problems with PCI Steering

    PCI Steering
     
  6. scriptasylum

    scriptasylum Moderator

    Messages:
    832
    Location:
    Des Moines,IA
    Some BIOSes let you perform some rudimentary adjustments to IRQ settings. Try messing with that (record where everything was first tho).

    Also, try to keep the first PCI slot near the AGP port free. For some reason, that has solved a problem for me in the past (can't remember what the problem was though).
     
  7. scriptasylum

    scriptasylum Moderator

    Messages:
    832
    Location:
    Des Moines,IA
    Doh!

    I guess I should have read this post more carefully before responding. :eek:
     
  8. RogerPhillis

    RogerPhillis Guest

    Agree with taurus , dont mess about with ACPI, but look for other answers.
    Usually if you have the display on 480 x 640 ,no screensaver, or background progs, it will work .
    May be you DVD software is at fault otherwise and needs updating.
     
  9. Funkyb

    Funkyb Simple

    Messages:
    82
    Location:
    Melbourne, York
    What I have done is updated the drivers for the graphics card which came out only a couple of days ago and all 'seems' well at the moment.
    Thanks for all the input
     
  10. MdSalih

    MdSalih The Boss

    Messages:
    1,730
    Location:
    Birmingham, UK
    Moved to the brand spakin' new *Graphics Cards* sections :)

    MdSalih