getting boot.ini to work with xp/98se

Discussion in 'Windows Desktop Systems' started by dedbob, Dec 22, 2001.

  1. dedbob

    dedbob Guest


    i had my machine working with windows 98se on a 40gb hard drive..
    i need to use sql server on that machine, so i was going to put in a spare 8gb hard drive i had lying around as a secondary machine, install winxp on it, and use that for my sql work.

    i temporarily unplugged the 40gb drive and installed xp on the 8gb by itself to get it up and running, then hooked the 40gb back up.

    now, when the 8gb xp drive is master it boots up to xp fine, and i can see the 40gb as my d: drive..

    i went into the boot.ini editor and added the following:

    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows 98 Second Edition"

    when the boot loader comes up, i select windows 98 and it starts to load and then gives me an error about not finding "hal.dll" in the system32 folder. i put this file in the win98 system32 folder and it gives me an error about not finding "ntoskrnl.exe" in the system32 folder. putting this file there then gives me a "dll not registered" error.

    now, these are nt system files, so it should not be looking for them on my 98 partition, should it?

    any ideas how to solve this problem? did the disconnecting of the 40gb win98se drive during the winxp install cause this?

    thanks in advance.

  2. Lonman

    Lonman Bleh!

    I'm pretty sure you'll have to re-install XP. There's certain files that have to be on the boot volume and if you have Win95 or 98 installed they need to be on the main boot drive/partition.

    Boot up in 98 and run the XP setup from there. Go to the i386 folder on the CD and run Winnt32.exe (windows install), or if you want to install from dos run winnt.exe. XP setup will recommend an upgrade but choose no, you want a clean install. A little later in the setup it will give you the option for which partition to install it on. Select your partition/drive and it will set up everything, including your boot loader.

    Yeah, you should have left your 40 gig plugged in. And make sure it's the master boot drive (98) when you do your install.
  3. dedbob

    dedbob Guest

    yeah, it seems to be working fine now..
    that was the problem.. i should have let windows figure out the boot.ini itself, instead of manually doing it.

    but still, my boot.ini looked the same as the one xp created automatically, so it *should* have worked! ;)

    oh well, thanks for the help!