funny network issue

Discussion in 'Windows Desktop Systems' started by ElementalDragon, Jan 16, 2004.

  1. ElementalDragon

    ElementalDragon The One and Only

    Messages:
    3,159
    Location:
    Lehighton, PA
    Ok, here's my problem.
    i have my Desktop sharing my internet connection with my laptop. My laptop can get internet access through the desktop, but neither the desktop nor the laptop can see each other's shared files.
     
  2. albybum

    albybum Penguin Rancher

    Messages:
    280
    Location:
    Elizabethton, TN
    I found this on the MS Knowledgebase. It might help.

    CAUSE
    This behavior can occur if both of the following conditions are true:
    NetBIOS over TCP/IP is not turned on (enabled) on one or more computers in the workgroup.

    -and-
    The Computer Browser service is not started or is turned off (disabled) on one or more computers in the workgroup.

    RESOLUTION
    To resolve this issue, make sure that NetBIOS over TCP/IP is turned on and the Computer Browser service is running on each computer in the workgroup. To do this, follow these steps.

    Step 1: Turn On NetBIOS over TCP/IP
    Click Start, click Control Panel, and then click Network and Internet Connections.
    Click Network Connections.
    Right-click Local Area Connection, and then click Properties.
    Click Internet Protocol (TCP/IP), and then click Properties.
    Click the General tab, and then click Advanced.
    Click the WINS tab.
    Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
    Click Close to close the Local Area Connection Properties dialog box.
    Close the Network Connections window.

    Step 2: Start the Computer Browser Service
    Click Start, right-click My Computer, and then click Manage.
    In the console tree, expand Services and Applications.
    Click Services.
    In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
    Close the Computer Management window.
     
  3. ElementalDragon

    ElementalDragon The One and Only

    Messages:
    3,159
    Location:
    Lehighton, PA
    well that figures. i solve part of the problem, and another part get's added, though i'm not sure if the second part is fixable.

    now, i can see my laptop's shared folders with my desktop, but every time i try to look at what's in them, explorer crashes.

    on a further note: when on the laptop, i can see the Desktop in the workgroup computers, but if i double click on it, it asks for a password.
     
  4. dreamliner77

    dreamliner77 The Analog Kid

    Messages:
    4,702
    Location:
    Red Sox Nation
    I had this same problem. Enabled NetBIOS. Tried to start Computer Browsing service but got this error: 1068 The dependency service or group failed to start. Anyone got some help?

    Edit, got it running, Apparently I turned off the workstation service.

    But I still can't get on the workgroup...

    Says I don't have permission.
     
  5. ElementalDragon

    ElementalDragon The One and Only

    Messages:
    3,159
    Location:
    Lehighton, PA
    ok, nother update. i still can't access my desktop's shares from my laptop. explorer.exe still crashes if i try to get into the laptop's shared C drive from my desktop, but my desktop can get into my laptop's "Shared Document's" folder without any crashes.
     
  6. sean.ferguson

    sean.ferguson Moderator Folding Team

    Messages:
    1,693
    Location:
    Fife; Scotland
    when this happens you might also want to double check a few simple things first

    pinging the IP of the other PC and then trying to use the UNC to connect to the pc, open up the run window and type \\ip.here
     
  7. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    What OS are both running? Dont depend on the network neighborhood for you network, it is unreliable at best. tehKore's method above is how you should check your connection, by IP, or netbios name.
     
  8. ElementalDragon

    ElementalDragon The One and Only

    Messages:
    3,159
    Location:
    Lehighton, PA
    Well, they're both running XP Pro. and i don't think it would be a problem with IP's and stuff like that since my desktop can partly connect to the laptop.
     
  9. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Both running XP Pro, disable simple file sharing and have identical user accounts on both PC's. It can take up to ten minutes for the computers to show up in the network neighborhood.
     
  10. rushm001

    rushm001 In the beginning...... Political User

    Messages:
    3,480
    Location:
    Norfolk, UK
    When j79zlr say identical it means passwords too!
     
  11. ElementalDragon

    ElementalDragon The One and Only

    Messages:
    3,159
    Location:
    Lehighton, PA
    i still don't see why having identical names and identical passwords would help since the desktop can somewhat access the laptop. could someone explain that to me please?
     
  12. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    XP verifies share access by username/passwords
     
  13. ElementalDragon

    ElementalDragon The One and Only

    Messages:
    3,159
    Location:
    Lehighton, PA
    ....o....k. and if you had read the entire thread, i am able to access my laptop's "Shared Documents" folder from my desktop, but can't look on my laptop's shared C drive from my desktop, and the laptop doesn't see the desktop at all, allthough it can get internet access through the desktop. so there is some connection, it just ain't going right. and i now have same exact usernames and passwords, and still the same. i would check if explorer.exe crashes if i try to browse my laptop's C drive, but i don't feel like having to log off and back on so the rest of my software can load.
     
  14. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    check the NTFS security permissions on the shares, make sure that the share permissions are set to everyone
     
  15. sean.ferguson

    sean.ferguson Moderator Folding Team

    Messages:
    1,693
    Location:
    Fife; Scotland
    only do this if you are the only user using the system, the "Everyone" group is very insecure. If there are more than you using the network then delete ("remove") the Everyone group and add any users that use the system to the list.

    Then give each member or each members group the approriate permissions.
     
  16. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    You should use NTFS security permissions to lock down access, but leave the share permissions at their default.
     
  17. sean.ferguson

    sean.ferguson Moderator Folding Team

    Messages:
    1,693
    Location:
    Fife; Scotland
    sorry J i missread i though you were talking about the NTFS everyone group, my bad