FTP server behind a broadband router

Discussion in 'Windows Desktop Systems' started by sshenriksen, Nov 1, 2003.

  1. sshenriksen

    sshenriksen Guest

    Hi all. It has been a long time since I have been in here. I have a problem. I have a FTP server running. This has not had a problem until we got rid of 4 IP addresses and got a router on 1 IP address instead. I know I have to open a port on the router and make it point towards my internal IP, but I cant figure the stuff out about NAT'ing. I hope somebody can help me.

    The router is SMC brand model number: SMC7004VBR V.2

    This setup is in NAT under virtual server. The ... indicate where I have to make a choice.

    Private IP:
    192.168.2. ...

    Private Port:
    ...

    Type:
    TCP/UDP ???

    Public Port:
    ...

    I hope this makes sence to somebody.

    Thank you for helping.

    Sune
     
  2. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    maybe
    192.168.2......
    21
    TCP
    21

    see if that works
     
  3. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Yes, plus you should forward a range of ports for passive connections (standard in most FTP clients). Add a range of, say, 100 ports, say, 10000 - 10099. Then set the same range in the settings of you FTP server software. Most servers should have this option.
     
  4. sshenriksen

    sshenriksen Guest

    I have tried the port 21. But not the second thing with passive ports. How do I do that. Is it on the router or just in the FTP server. I was able to figure it out there, but can't find anything on the router.

    By the way. thanks for the quick response. That's nice.

    Sune
     
  5. sshenriksen

    sshenriksen Guest

    I found this: SMC
    and this: BPFTP I think I get most of it, but I just have to find a tester. Then I shall return with the results. Thanks again.

    I am getting some connection, so now it is to the fine tuning.

    Sune
     
  6. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Don't forget to forward port 20 as well on your router for FTP, as well as 21. All the clients connecting with your server will now need to uncheck the PASV setting on their client FTP software. You can start changing ports altogether when you grow accustomed to having your server up and running first through the router. Nat'ing is needed on the client side connecting to your server.

    Heeter


    Heeter
     
  7. sshenriksen

    sshenriksen Guest

    The problem I have is this and the solutions doesn't help:

    Q3 - My users can not list (425 Cannot open data connection (10060))
    1) If you are behind a router / firewall check FAQ : BPFTP Server behind a router
    2) If remote user is behind a firewall, tell him to switch his ftp client to passive (PASV) mode
    3) Check that this user have right to list (+L) in user account / access rights
    4) FTP Client is behind a NAT, you should see a list attempt with PORT 192,168... command or PORT , user should switch his ftp client to PASV (passive) mode.
     
  8. sshenriksen

    sshenriksen Guest

    Sorry about all that. I finally got it all to work. It made it easier when both run passiv or active instead of opposite.

    Sune

    Thanks for your help anyway.
     
  9. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    - Port 20 is not needed for passive (PASV).
    - If a client has NAT he must run in passive mode (unless he/she forwards an own range).

    This is why setting up a server, it is best to make it passive compatible, i.e. to forward 21 plus a passive range of ports.