frame.htm help

Discussion in 'Windows Desktop Systems' started by omgsoup, Mar 18, 2003.

  1. omgsoup

    omgsoup OSNN Senior Addict

    Messages:
    284
    so i have this code to have frames on my site:

    <HTML>
    <HEAD>
    <TITLE></TITLE>
    </HEAD>
    <FRAMESET COLS="15%,*" FRAMEBORDER=NO>
    <FRAME SRC="navbar.htm">
    <FRAME SRC="main.htm" NAME=DISPLAY>
    </FRAMESET>
    <NOFRAMES>Noframes content...
    </NOFRAMES>
    </HTML>

    not really knowing much about html, i sorta got this off of a "how to" site, but it didn't really explain my problem i've now encountred. when i click on a link in the navbar, the new page opens where the nav bar is, not where the main portion of the site is. any ideas on how to modify the code to stop that would be great.
     
    Last edited: Jul 7, 2012
  2. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Just guessing.
    Try changing the link from main to index. (where the two pages come together)
     
  3. omgsoup

    omgsoup OSNN Senior Addict

    Messages:
    284
    nope that just makes the nav bar on the right, when i want it on the left
     
  4. omgsoup

    omgsoup OSNN Senior Addict

    Messages:
    284
    here's all the *.htm files - but wait!! i got it to work! so i guess you don't really need to look them over if you don't want to.
     
  5. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Use the TARGET attribute:
    PHP:
    <A HREF="whatever.html" TARGET="DISPLAY">Link</A>