Flash Drive not detected on front USB ports

Discussion in 'General Hardware' started by mightymo, Feb 1, 2005.

  1. mightymo

    mightymo OSNN Junior Addict

    Messages:
    23
    I bought a 1GB PQI Intelligent Stick 2.0 flash drive. For some reason it doesn't work on my front USB ports. I have two in the front and four in the back. It works fine in the back. I never had any problems with my front USB ports and I use my digital camera in the front all the time. Any ideas?
     
  2. well first check if it's usb2.0, if it is then when you plug in the drive and you see that lil bubble in that the drive is installed and ready to use if it and you can't see it in my computer then you need to change it's drive letter
     
  3. tibboh

    tibboh Arte et Marte

    Messages:
    235
    Location:
    Preston England
    Funny you should mention that, I have the same problem where the flash drive will not be recognised by the front two USB 2 ports, but is okay on the rear four. And yet I can plug any other USB device into the front ports, and they work fine. Checked wiring etc and all is OK.
     
  4. Brad

    Brad Moderator Political User Folding Team

    Messages:
    2,280
    Location:
    Cary, NC
    maybe it likes it better in the butt...
     
  5. zeke_mo

    zeke_mo (value not set) Staff Member Political User Folding Team

    Messages:
    1,984
    Location:
    Placerville, CA
    Thats bad :p
     
  6. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    Strange. My 2.0 Drive works fine in a USB 1.1 socket.

    But your 2.0 drive may not be backward compatible. Most of the MBs have some USB 2.0 ports and the rest are USB 1.x. Check your MB the front ports may be 1.x

    One guy I know says he has had problems with an ASUS NF2 not liking some of his devices (scanner and cd tower) so check for any new MB USB drivers and MB Bios updates. Come to think of it my camera does not always get recognized properly when I plug it into my new USB 2.0 HUB. Used to work fine off 1.x HUB.
     
  7. mightymo

    mightymo OSNN Junior Addict

    Messages:
    23
    Cool, I just called Antec and they said they had a problem back in 2003 with the USB ports not reading USB 2.0. So I was right, my flash drive doesn't work on 1.1 ports for some reason. They are going to send me the little USB board for me to replace. Awesome.
     
  8. zeke_mo

    zeke_mo (value not set) Staff Member Political User Folding Team

    Messages:
    1,984
    Location:
    Placerville, CA

    Wow, thats worth it just to buy the 1.1 drive :p
     
  9. niice
     
  10. mightymo

    mightymo OSNN Junior Addict

    Messages:
    23
    OK I got the new front USB board and installed it. Flash drive works now, so that was the problem.