Firefox standard instead of IE

Discussion in 'Windows Applications' started by hansrijf, Feb 23, 2008.

  1. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    Hello,

    I am using Vista Business with Firefox and want to set Firefox as the standard browser. So everytime I start FF I click the button to make FF the standard browser, but it doesn't work. Is there a way to stop IE7 from making itself the standard browser (I tried all the standard things in the configuration options but I think I must change a registersetting)
     
  2. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    I think you need to run firefox elevated and tell it to be the default browser. At least that's what I remember when I used Firefox with Vista a while back (I'm back on XP)
     
  3. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    And "Firefox elevated" meaning......???
     
  4. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    control panel -> default programs -> set program access and computer defaults -> custom

    tick firefox there
     
  5. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    Yes, tried this too. Problem is there is no FF icon, only a IE7 one to tick...
     
  6. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,932
    Location:
    Seattle
    Have you tried from the run box?

    firefox.exe -silent -setDefaultBrowser
     
    hansrijf likes this.
  7. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    No, haven't tried this one yet. Will do so and let you know. Thanks 4 the tip!
     
  8. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    hansrijf likes this.
  9. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
  10. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    well, I assigned the extensions .htm, .html and .url to FF but I do not have the protocols http and https in the list. So, even though I have excluded IE7 in the standard programms list (make in unaccessable? - I have Dutch Vista), webpages still open in IE7...
     
  11. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    all i did was set firefox as default and disallow access to IE and firefox always opens here
     
  12. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands

    wish it was the same here, thinking about reinstalling vista anyway...
     
  13. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    well if you untick IE it shouldn't run nor should the icon be on the desktop or quick launch tool bar
     
  14. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Did you try the run as method described on that page? It runs Firefox with admin privileges which will let it set itself as the default browser.
     
  15. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    Yes I did, but it didn't help. I am going to reinstall Vista tomorrow. Think I have messed it up..
     
  16. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    I've never had to do any of these obscure methods described above. In firefox, have you tried going to Tools > Options > Main and click on "Check Now" to see if firefox is the default browser?
     
  17. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    Yep, tried this too a couple of times and everytime FF is the standard browser. Until I close FF and start it again, then I get the question again if I want to make FF the standard browser. Funny thing is that on my XP desktop everything works fine, it's just Vista on the laptop that makes trouble...
     
  18. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    I ran into something similar a couple of weeks ago when I uninstalled a beta build of Firefox 3 -- I couldn't set Firefox 2 as the default browser again after that. It seems like installing v2 and v3 side-by-side screws up some settings.

    I just had to reinstall Firefox 2 over the existing setup, and everything was okay after that. You could try that and see if it helps.

    Also, you don't need to elevate in Vista to set it as your default browser since it's a per-user setting.
     
    hansrijf likes this.
  19. hansrijf

    hansrijf sh! it stinks Folding Team

    Messages:
    277
    Location:
    Amsterdam, The Netherlands
    This could be it. I had FF3beta installed also and have removed it afterwards. I will try with reinstalling FF, is a lot easier and faster than reinstalling Vista and all the other software!