File & printer share refuse to work over network

Discussion in 'Windows Desktop Systems' started by Rigsta, Aug 8, 2003.

  1. Rigsta

    Rigsta OSNN Addict

    Messages:
    98
    OS: Win XP

    I have 4 computers connected via a peer-to-peer network at home. Two XP and one '98 computers are happily sharing files, and are visible in the network neighborhoud/workgroup view. The last computer simply doesn't do it.

    It is set up corretly as far as I know (the setup in XP is as complex as ticking a checkbox), but it does not display the other network computers in it's workgroup view, and none of the other computers seem to be able to see it.

    The PCs are connected via a linksys router, all on the same workgroup.

    Any thoughts?


    Incidentally, does anyone know how to password protect shared folders in XP? Considering it gives you a security warning when you share a folder, I thought this would have been a pretty basic option.

    Edit: Ohps, edited the wrong thing - sorry - ingore, nothing major
     
  2. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    XP Home or Professional?
     
  3. Un4gIvEn1

    Un4gIvEn1 Moderator

    Messages:
    1,084
    be a little more specific.... like this...


    PC1 Windows XP DHCP Working
    PC2 Windows XP STATIC 192.168.1.103 Working
    PC3 Windows 98 STATIC 192.168.1.102 Working
    PC4 Windows 98 DHCP Not working

    Also... do you have a domain controller? ( I would assume no) Is the router controlling DHCP or one of the PCs? Are you able to ping all of the PCs? Do you have admin password set on the Windows XP machines? XP Pro or Home (as stated above)... These are important
     
  4. Rigsta

    Rigsta OSNN Addict

    Messages:
    98
    I only included what was going wrong, since everything else works... LAN games, internet access, etc. Plus, I didn't think they had any effect on this particular feature of windows networking.... In other words, try to avoid writing an essay on the subject.

    Router: Linksys somethingorother... to be honest, I'd rather not release that detail to the public without dire need.

    DHCP: Enabled on the router. All computers are configured to automatically obtain an IP address, on the workgroup "Thewired". All computers are able to access the internet and we can play games on our little LAN with no problem at all.

    PC1: XP home laptop, working fine.
    PC2: XP pro PC, working fine.
    PC3: *shudder* '98 PC.... working fine.
    PC4: XP pro PC, not visible in network browser/workgroup, unable or unwilling to display other networked PCs.

    Domain controller? no idea what that is. The network is not set up to use a domain, just a simple peer-to-peer (well, I suppose the router acts as a Server, making it a client-server architecture) workgroup.

    A different admin password has been set on each computer, although I might as well not have bothered since windows has yet to challenge me for a password except when trying to change the password lol :p (Apart from my laptop, which is set to require a log-in.... no-one else likes logging in and I'm not about to force them to).

    I personally suspect a problem with the file/printer sharing capability of PC4, since everything else appears to work as it should.
     
  5. Un4gIvEn1

    Un4gIvEn1 Moderator

    Messages:
    1,084
    Ah... a Serial Experiments Lain fan...


    are you able to ping the non-working PC from another PC?

    verify you are pulling an IP address on the non-working PC by running IPCONFIG
    verify you are able to ping that PC. If you are unable to ping that PC then that is your problem.
    try to ping other PCs from the non-working PC.
    verify "Client for Microsoft Networks" and "File and Print Sharing" are enabled.
    verify that the XP firewall is not turned on.

    Good luck!
     
  6. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    I believe that your problems lie in not having passwords. You should use user-level share access, not share level (instead of password protecting shares, you give user rights to access) Disable simple file sharing on the XP Pro machines. Then boot into safe mode on the XP Home machine to access the security tab for the shares inorder to control access.

    If you really don't want to do this (although I suggest you do), make sure that the Guest account is enabled on the new XP box, and double-check to see if it is in the same workgroup.
     
  7. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    Passwords are not required to network.

    It sounds like the 4th PC is surfing and gaming ok from one of your earlier posts. If so all the hardware and cabling IP assignments and DHCP and hub are fine.

    Check the obvious. Did Windows turn on it's built in firewall on that last PC? If it did the other 3 won't be able to see that PC.

    Did you install some other firewall software on the last PC? Is it set to allow the LAN to be open?

    Have you set up your network as a domain. If so then all the PC's have to ahve the same domain name. Windows defaults it to some obvious name I forget. Check under netwokr in control panel.

    As for setting passwords on files or folders that takes NTFS file system. FAT32 doesn't support it.
     
  8. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    actually, you can control shares by usernames/groups on FAT32 drives, but not security permissions. With XP home you have to use CACLS from the command prompt.

    couldn't have set up a domain, there is no domain controller, you would need an NT or 2000 server to do so.

    I agree though, the firewall is probably it.

    Simple file sharing requires the guest account, since all incoming connections are received through the guest account and share access would be regulated by the permissions given to Guest.
     
  9. Un4gIvEn1

    Un4gIvEn1 Moderator

    Messages:
    1,084
    You are wrong... Windows XP disables sharing of resources if there is not an admin password set!
     
  10. Un4gIvEn1

    Un4gIvEn1 Moderator

    Messages:
    1,084
    You can not simply set the Security settings for a Windows XP PC. You will need to set Share Permissions.
     
  11. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    I feel sorry for the guy who asked this question, been hijacked. :)

    You should always leave the share permissions to Everyone, then change access to the share with NTFS permissions, unless on FAT32 of course.
     
  12. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    Gee, it does?

    Then I better tell the 3 PC's I have networked together and sharing 2 printers, 5 hard drives and 6 cd rom's that they can't talk to each other anymore.

    None of my systems have passwords.
     
  13. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    un4given should have mention that this is true for XP Pro with simple file sharing turned off.
     
  14. Rigsta

    Rigsta OSNN Addict

    Messages:
    98
    :D That anime is just to wierd not to be cool... Oh, and what gave me away? Was it the Lain reference or the subtley anime-themed sig pic? ;P Anyways...


    A ping to the computer name fails. A ping to the computer's IP address succeeds.

    I can tell it's getting an IP address by looking at the router's DHCP client log - the IP also follows the router's numbering scheme.

    Is there something I'm missing? any other, more important, way to change XP pro's file/print sharing settings other than setting the properties of the LAN connection in the network connections window?

    How do I go about doing that? (on both home and pro) When I opt to share a folder, the only options available are "share this folder" and "allow network users to change my files". As a side note, I wonder if they fired to the idiot who decided to have the latter option enabled by default. Seriously, how the hell did that one pass quality assurance testing....

    The reason for the passwords (and the gripe) is to keep worms and virii out.... I was unaware that write access was enabled by default, so you can imagine me being rather surprised when AVG started going mad when I connected to the college network and it started working overtime to quarantine the files that copied themselves into an open network share :/ Oh well, good demonstration that AVG works, it locked it down almost before I'd unplugged the cable...

    Whoops, rambling a bit ;) *edit* LOL, I'm not the only one though XD
     
  15. Un4gIvEn1

    Un4gIvEn1 Moderator

    Messages:
    1,084
    Enable NetBIOS over TCP/IP on the XP machine that is not working. Then try to ping again.
     
  16. Un4gIvEn1

    Un4gIvEn1 Moderator

    Messages:
    1,084
    Open Explorer
    Tools
    Folder Options
    View
    "Use simple file sharing" uncheck that...