File and Print sharing over a home network...

Discussion in 'Windows Desktop Systems' started by vivid_vibe, Jun 18, 2006.

  1. vivid_vibe

    vivid_vibe OSNN Senior Addict

    Messages:
    406
    Hello all,

    I am new to the world of networking and have just set up my first one. It is a small home network involving only 2 computers (and the router transmits a wireless signal as well). I have the 2 computers successfully sharing an internet connection, but I want to be able to access files on one computer from the other one, and vice versa. I also want both to be able to print to the same computer. What exactly should I do to have this made possible. I ran the new network connection wizard from windows on the main computer, but it didn't seem to do anything or complete successfully. I would very much appreciate any help from you networking gurus :). Thanks alot,

    vivid
     
  2. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    1) Run the network wizard and select file and print sharing on both machines. Give them both the same workgroup name (defaults to MShome I think). Reboot both PCs and you should ne able to see them under network places.

    2) Add the printer as a network printer on the "other" computer. You will need to install drivers

    3) For initial checkout after doing the setup, reboot and turn off all firewalls.
    You will only be able to see and share printers and folders that have been set to "shared". There is a default shared directory on each computer. Go to properties, security to open up additional folders as desired.

    4) Once you know your setup is working then turn the firewalls back on and set the firewall to put the LAN addresses in the trusted zone.

    It's that simple. Of course it never works out that easy... Post back with any specific problems you run into.

    For security you want to set the wireless router up fro WPA security, hide its. name etc. even if you are not connecting wirelessly yet. In the mean time just remove the antenna. But that's another thread (which is around here somewhere).
     
  3. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    not sure you HAVE to run the wizard....

    Use simple file sharing
    Enable Guest account
    Share directories you require

    The default workgroup is called WORKGROUP

    There are a number of threads with this also....
     
    vivid_vibe likes this.
  4. vivid_vibe

    vivid_vibe OSNN Senior Addict

    Messages:
    406
    How do you do these things without running the wizard? Sorry, I'm a bit of a noob when it comes to networking. I've tried running the wizard on both computers but it still does nothing as far as connecting them. What should I try next?

    vivid
     
  5. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    To check if simple file sharing enabled - from explorer window >>> Tools >>> Folder Options >>> View tab >>>> Scroll to end and check if "Use simple file sharing (Recommended)" is ticked.


    To check guest accoung enabled - Control Panel >>> User Accounts

    To check directory sharing properties right click >>> Sharing and Security....

    Note that you are able to share at drive level, but will be warned in so doing and have to override if you wish to do so. Also I believe it is not possible to share the "Program Files" or Windows directories.... though not sure why you might want to.

    This should be all you need to know to get going I think.
     
  6. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    The networking wizard does nothing useful. I'd never suggest running it. Usually it just creates a network bridge with your IEEE card. If these are XP Home PC's, just share something, the guest account need not be enabled.
     
    vivid_vibe likes this.
  7. vivid_vibe

    vivid_vibe OSNN Senior Addict

    Messages:
    406
    Well, I have made a little progress. My computer, known as DEN, can see itself on the network. But, my father's computer, known as DAD, can neither see DEN nor itself. DEN does not see DAD either. I hope that's not terribly confusing. I've tried all suggestions, and even a few things I read elsewhere, but to no avail. Anything else I can try?

    vivid
     
  8. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    Can each machine PING the other?

    RUN ipconfig to see the IP address for each machine and then open command prompt and PING from one to the other....

    You have to ensure this is working first.
     
  9. vivid_vibe

    vivid_vibe OSNN Senior Addict

    Messages:
    406
    I tried to ping each computer from the other, and it just times out. They can however ping themselves (not sure if that means anything). This is driving me nuts!!!
     
  10. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Usually means you are firewalled. How are the IP's assigned to the PC's?
     
  11. vivid_vibe

    vivid_vibe OSNN Senior Addict

    Messages:
    406
    Each computer is running Zonealarm actually. As far as the IP addresses, I believe the router is assigning them. They are only one digit apart.
     
  12. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    If you want to verify this is ZoneAlarm - then suspend it on each computer and you should find you can then ping the other....

    If for whatever reason this bothers you - then you'll need to add each as a trusted zone for the other I guess - should be able to add 192.168.1.* I would have thought anyway, I am guessing that will cover your IP addresses if they are assigned by the router. This is exactly what firewalls do - so a good time to understand their operation and how to set them if you intend using them.
     
  13. vivid_vibe

    vivid_vibe OSNN Senior Addict

    Messages:
    406
    Eureka! Zonealarm was the culprit. I just allowed each IP address on each computer and that did the trick. I actually feel quite stupid that the firewall never occurred to me. I'm just so used to running a firewall program that I sometimes forget that it's there and doing its job. Thanks for everyone's tips. :)

    vivid