Explorer.exe 99% CPU usage

Discussion in 'Windows Desktop Systems' started by smoothyuk, May 9, 2005.

  1. smoothyuk

    smoothyuk OSNN Junior Addict

    Messages:
    32
    Here's an interesting problem, I open Windows Explorer and navigate just fine, but as soon as I right click a file or folder the CPU usage jumps to 99% and stays there until I click away (effectively removing the right click menu). I noticed this on my laptop (AMD64 3200+ 512mb Ram) as the fan goes nuts at this CPU usage level, but something similar happens on my desktop machine too (shoots up to about 50% instead of 99%). This problem is a recent developement (at least on my laptop) so what could be causing this problem? And how might I go about fixing the issue?

    I'm about to embark on uninstalling all recently installed apps to see if that rectifies the issue, but I have a feeling it's not going to be that simple.

    Thanks for in advance for any suggestions. :)
     
  2. muzikool

    muzikool Act your wage. Political User

    For starters, how about a system restore?

    Have you done all of the basic maintenance such as running security apps (spyware, hijack etc.)?

    There's the sfc /scannow run command as well which might be worth a shot.
     
  3. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    I think I have the same laptop...not the same behavior on my box

    anyway, I'm guessing a virus or spyware...do some scans
     
  4. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,931
    Location:
    Seattle
    XP contains a known bug that causes the CPU usage to spike to 100 percent when you access the context menu under certain configurations.

    There are two ways I know of to work around this bug.

    One is to disable the GUI's transition effects by performing the following steps:
    1. Start the Control Panel Display applet.
    2. Select the Appearance tab.
    3. Click Effects, then clear the "Use the following transition effect for menus and tooltips" check box.
    4. Click OK to close all dialog boxes.
    The other solution that often works is to left-click the file or folder before right-clicking to display the context menu.
     
    muzikool and smoothyuk like this.
  5. tzepp@cox.net

    tzepp@cox.net high

    Messages:
    137
    Location:
    Sandy Eggo
    I was jsut gonna start searching for that thread. I remember that being reported here over a year ago.
     
  6. smoothyuk

    smoothyuk OSNN Junior Addict

    Messages:
    32

    Perfect! Problem solved. Thanks for this, I never would have figured that out.