Error Code #2 everytime i boot up.

Discussion in 'Windows Desktop Systems' started by jaxxsterz, Jan 18, 2002.

  1. jaxxsterz

    jaxxsterz Guest

    Everytime i boot win xp pro. i get error code #2.
    right after my settings are restored. I don't know
    what or if the error is causing any problems.

    can anyone shed some light on this.

    thanx
     
  2. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    Code 2
    Depending on which device is failing, you may see either of two different messages. This code means that the device loader (DevLoader) did not load a device. When this device is a Root Bus DevLoader (for example, ISAPNP, PCI, or BIOS), the following message is displayed

    Windows could not load the driver for this device because the computer is reporting two <type> bus types. (Code 2)

    Contact your computer manufacturer to get an updated BIOS for your computer.

    where <type> is ISAPNP, PCI, BIOS, EISA, or ACPI.

    Solution button: None

    When the device is not a root bus DevLoader, the following message is displayed

    The <type> device loader(s) for this device could not load the device driver. (Code 2)

    To fix this, click Update Driver to update the device driver.

    where <type> is the DevLoader such as FLOP, ESDI, SCSI, and so on.

    Solution button: Update Driver

    In addition to following the recommended solution, try removing the device from Device Manager, and then running the Add New Hardware wizard.
     
  3. jaxxsterz

    jaxxsterz Guest

    Thanks for the reply. Thing is, all i get is
    error code #2. I get no device driver error
    or any other error msgs. I'm stumped!
     
  4. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Next time you boot up, get a screen shot of the error that gets displayed. I can't find anything about 'error code #2.'
     
  5. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    well thats a code 2 in device manager, the cause of most problems, if its another one then....damn