Error 1717: The Interface is Unknown

Discussion in 'General Hardware' started by icompute, Sep 17, 2003.

  1. icompute

    icompute Guest

    I am running W2K on a Dell notebook C610,512Meg Mem. I log into a company VPN. All worked fine untill I installed SP4. Now I get an "Error 1717: Interface is Unknown" , just as as the dialog box goes to "Verifing Username and Password". It hang there and then tries to reconnect (I have it set to try 3 times). I have a cable connection thru a Linksys router. What did SP4 change that would have caused this ? The pc had SP2 and I up'ed to SP4, thats when it all happened.....All Help apprecdiated

    Len
     
  2. Enyo

    Enyo Moderator

    Messages:
    1,338
    Ensure the Remote Access Connection Manager service is in the running state and set to start automatically.

    Check the event log for any error messages that may be relevant so we have some more info to work with.
     
  3. icompute

    icompute Guest

    RACMS is in automatic and running. The only Event log that has anything that looks suspicious is the Security log .......

    Event Type: Failure Audit
    Event Source: Security
    Event Category: Object Access
    Event ID: 560
    Date: 9/17/2003
    Time: 8:23:56 AM
    User: NT AUTHORITY\SYSTEM
    Computer: XXXXXXXXXX
    Description:
    Object Open:
    Object Server: Security
    Object Type: Mutant
    Object Name: \BaseNamedObjects\RasPbFile
    New Handle ID: -
    Operation ID: {0,149563}
    Process ID: 1224
    Primary User Name: XXXXXXXXXX$
    Primary Domain: XXXXXXX
    Primary Logon ID: (0x0,0x3E7)
    Client User Name: -
    Client Domain: -
    Client Logon ID: -
    Accesses DELETE
    READ_CONTROL
    WRITE_DAC
    WRITE_OWNER
    SYNCHRONIZE
    Query mutant state

    Privileges -

    the X's are mine.
    There are about 10 or 12 of these errors in a row. Maybe the MUTANT has something to do with the error. Hope this is the info needed.
    Thanks ..... Len
     
  4. Enyo

    Enyo Moderator

    Messages:
    1,338
    That suggests it cant access the RAS Phone Book and ties in with a error discussed here which metions "Cannot load phonebook Error 1717: The interface is unknown" when trying to create a VPN connection.

    That event however may be totally ignorable, the information i have seen contradicts other articles.

    If it cant read the phone book it may not be able to access all the security and network settings it requires to complete the connection.

    Is the Rasphone.pbk file in the Winnt\System32\Ras and accessable?

    Can you create a new VPN connection?

    Maybe an idea to enable RAS tracing to see if that gives some more insight.

    Also repeat your question in the MS RAS newsgroup.
     
  5. icompute

    icompute Guest

    VPN ERROR

    I can make a new VPN connection and it gives the same error.
    I activated RAS tracing, but I do not know how to interpret the capture log, I can see where the error code is set to 1717 but I can not decipher what leads up to that point. The rasphonebook file is in the correct location (several to be exact) and accessable.

    Could there be a .DLL or some other file that SP4 changed that I could copy over from another W2K machine? I have the feeleing that that is all it might take to fix me.

    Thanks

    Len
     
  6. Corvette

    Corvette Sauske!

    Messages:
    761
    How can he get that info if he can't even log in?! :eek:
     
  7. Enyo

    Enyo Moderator

    Messages:
    1,338
    What are you on about ViperSnake :rolleyes:

    icompute, i don't believe its going to be a matter of a single file. You would most probably not be able to write over it anyway as File Protection would reverse the action.

    I found someone having the same problem here and here and here.

    Despite the fact it seems a few people are seeing the same thing i have been unable to locate a fix.
     
  8. icompute

    icompute Guest

    ENYO..... Thanks for the effort so far!!! I looked at and tried the suggestions from the posts you referenced and had no luck. I have posted this problem on the MS board (networking, W2K) and have no responses yet. I hope MS ( or anyone for that matter) comes up with a fix pretty soon, I dread reinstalling W2K on this unit.




    Thanks......

    Len (icompute , but not well, lately)
     
  9. Enyo

    Enyo Moderator

    Messages:
    1,338
    Good luck Len, I'll be watching the thread over in the MS newsgroups :) Let us know if you find a fix.