dwwin.exe - application failed to initialize

Discussion in 'Windows Desktop Systems' started by TheBlueRaja, Nov 26, 2003.

  1. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Hey all,
    Every time i shut down i get a popup window saying that dwwin.exe - The application failed to initialize because the window station is shutting down.

    When i look in the event log i get:-

    Application popup: dwwin.exe - DLL Initialization Failed : The application failed to initialize because the window station is shutting down.

    For more information, see Help and Support Center at
    Blah de blah.

    Incidentally the link tells me nuffin, The Event ID for this is 26.

    Any Ideas? Even how i could find out what DLL its talking about?
     
  2. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Details
    Product: Windows Operating System
    ID: 26
    Source: Application Popup
    Version: 5.2
    Symbolic Name: STATUS_LOG_HARD_ERROR
    Message: Application popup: %1 : %2

    Explanation
    The program could not load a driver because the program user doesn't have sufficient privileges to access the driver or because the drive is missing or corrupt.


    User Action
    To correct this problem:

    Ensure that the program user has sufficient privileges to access the directory in which the driver is installed.
    Reinstall the program to restore the driver to the correct location.
    If these solutions do not work, contact Product Support Services.



    Version: 5.0
    Symbolic Name: status_log_hard_error
    Message: Unable to Load Device Driver : device driver could not be loaded.

    Explanation
    The program could not load a driver because the program user doesn't have sufficient privileges to access the driver or because the drive is missing or corrupt.


    User Action
    To correct this problem:

    Reinstall the program to restore the driver to the correct location.
    If these solutions do not work, contact Product Support Services.
     
  3. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    dwwin is DrWatson, a built-in debugger component in Windows.

    Go into regedit and open HKLM\SOFTWARE\MICROSOFT\WINDOWS\CURRENT VERSION\RUN and for dwwin.exe, change the value so it looks like "start /belownormal dwwin.exe /init"
     
  4. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Whoa - Thanks HandyBuddy for the very quick reply?

    But - hows that work and what going on?
     
  5. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    It's normally a message that should be suppressed, but it's not happening. I've hear a few things (one is that it's somehow related to Zone Alarm) but I'm not absolutely sure.
     
  6. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Ah - problem,
    dwwin.exe is not lister under that registry key, any ideas?
     
  7. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    Try this instead:
    go to HKLM\SOFTWARE\MICROSOFT\WINDOWS NT\CURRENT VERSION\AeDebug and change "Auto" to 0. If it's already 0, delete the value under Debugger.
     
  8. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Okay,
    I did that - then reset so that the registry setting change would take effect - then reset again.

    But - same problem...
     
  9. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
  10. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Hmm, im at work now but i did notice in that article that it says...

    AeDebug

    Value Name = Auto
    Type = String (REG_SZ)
    Data Value = 1 or 0. (Default is 1)

    Where my one was set to 0....