driver disabled the write cache on device DeviceHarddisk3DR3

Discussion in 'Windows Desktop Systems' started by jawshoouh, Aug 11, 2002.

  1. jawshoouh

    jawshoouh Guest

    driver disabled the write cache on device \Device\Harddisk3\DR3

    i've got 3 HDDs (primary master, primary slave, third on an additional IDE channel PCI card as 1st channel, master), 1 CD-RW (secondary master), 1 DVD-Rom (secondary slave), and 1 Zip250 IDE drive (on the additional IDE channel PCI card as 2nd channel, master). When i play DVDs, and sometimes when i'm just futzing around on my pc, but mainly when i'm playing DVDs, my computer crashes...just locks and dies. when i restart and check the Event Viewer, at the exact time my computer crashed, is this entry:

    Event Type: Warning
    Event Source: Disk
    Event Category: None
    Event ID: 34
    Date: 8/10/2002
    Time: 10:46:21 PM
    User: N/A
    Computer: SPILLEDMILK
    Description: The driver disabled the write cache on device \Device\Harddisk3\DR3.

    For more information, see Help and Support Center at
    0000: 0f 00 04 00 01 00 62 00 ......b.
    0008: 00 00 00 00 22 00 04 80 ...."..€
    0010: 01 00 00 00 10 00 00 c0 .......À
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    0028: 00 00 00 00 ....

    now, i found at microsoft's support site that this seems to be a problem with Zip250s and WinXP. a few questions:

    1) Is Harddisk3\DR3 my Zip250 or my DVD-Rom?
    2) If it's my Zip250, is the only way to fix this to remove it from my pc? i checked the Zip250's properties (at the Policies tab), and the item for Enabling/Disabling write caching is greyed out because it's not supported.
    3) If DR3 is my DVD-Rom, how can i prevent this error from occurring? get a different DVD-Rom? Is there a setting in gpedit.msc (group policy manager) that i can turn off write-caching for the DVD-Rom, because i can't seem to find anyplace to turn it off in the DVD-Rom properties.

    thanks in advance
  2. ignipotentis

    ignipotentis OSNN Addict

    The Zip should be recognized as a hardisk, therefore if you have 3 hardisks, and we start labeling them at 0, your zip will end up being Hardisk 3. Just do double check, goto your device manager, locate the zip drive, right click and goto properties... click on the volumes tab, then click populate. The top entry, disk... should be Disk 3. As far as a fix for the problem, i'm not sure at the moment... if i find something, i'll let you know.
  3. jawshoouh

    jawshoouh Guest

    my temporary fix solved the problem: i took the zip drive off my computer. and you were right, it was Drive 3.

    thanks for the help so far :)