Disabling "Set As Desktop Background"

Discussion in 'Windows Desktop Systems' started by prinsipe, Jul 10, 2006.

  1. prinsipe

    prinsipe Not Too eXPerienced

    Messages:
    208
    guys, do you know how to Disable the "Set As Desktop Background" feature?
    thanks for any help.......
     
  2. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    hmmmmMMM Posting here just to seond that question and get myself subscribed to this thread...

    I am curious and think if it is not tweakable as such should be.... M$ should even make it a visible option - because in a corporate situation this is just about the most of a gimme as something most corporate desktops would like "locked down" even if they are not slipstreaming and net installing crippled and customised installs anyway....

    So post up - I wanna hear too.... Surely tweakable.... :ermm::devious:;)
     
  3. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
    "NoDispBackgroundPage"=dword:00000001

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop]
    "NoChangingWallpaper"=dword:00000001
     
    Mainframeguy likes this.
  4. prinsipe

    prinsipe Not Too eXPerienced

    Messages:
    208
    Thanks for the reply but since I am not too familiar with regedit could you please make a step by step instruction how to do it? I would really appreciate it, i hope you will be patient enough to elaborate coz I dont want to mess up with my PC, thanks again
     
  5. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    As always, backup the reg before changing it,

    as a simple way of doing it, open a command prompt (start->run-> type "cmd" no quotes)
    and copy/paste / type this in

    reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop /v NoChangingWallpaper /t REG_DWORD /d 1

    try just that one first, may not need the other one.
     
  6. prinsipe

    prinsipe Not Too eXPerienced

    Messages:
    208
    I have done it, but all it did was to remove the "Desktop" Tab from the display properties window. changing wallpaper is still available via right clicking a picture file then seelecting Set As Desktop Background
     
  7. kcnychief

    kcnychief █▄█ ▀█▄ █ Political User Folding Team

    Messages:
    16,948
    Location:
    Massachusetts
    That will, by design, remove the Desktop tab from the Display Properties. If you want to remove the option to do so via a right-click, you should try his second option. And, fwiw (for what it's worth), I would recommend setting this at the HKLM level so that it's a global change.

    So, try this:

    Start - Run - copy and paste these into the dialog box and hit enter after each one. Remember to backup the registry before doing it and reboot to apply the changes -

    reg add HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop /v NoChangingWallpaper /t REG_DWORD /d 1

    reg add HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v NoDispBackgroundPage /t REG_DWORD /d 1
     
  8. prinsipe

    prinsipe Not Too eXPerienced

    Messages:
    208
    Followed your advices, the feature is still very much available
     
  9. jimi_81

    jimi_81 Moderator Political User

    Messages:
    820
    Location:
    Stoney Creek, ON, Canada
    Googling, I found this:
    So.. remove this entire entry?
    use at your own risk i guess.. or backup!
     
  10. kcnychief

    kcnychief █▄█ ▀█▄ █ Political User Folding Team

    Messages:
    16,948
    Location:
    Massachusetts
    Should always do a backup when working with the registry ;)

    Are these machines on a domain by any chance?