Disable screensaver

Discussion in 'Windows Desktop Systems' started by Baron_Flambe, Jan 26, 2003.

  1. Baron_Flambe

    Baron_Flambe Guest

    I have a restricted account on my pc at work, which is set up so that the screensaver kicks in after 15 minutes and locks the pc. Is there any way I can stop this happening? (other than wiggling the mouse now and then!)

    Access to control panel and right clicking on the desktop have been disabled by anal sysadmins, but I can access explorer and the command line.

    I'll be very happy if anyone can help!
     
  2. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Hit the windows key once. That will bring up the start menu. Leave it like that & the screensaver won't kick in. :)
     
  3. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Bah! Forget that. Just tried it. Win xp must be different from win9x. Big fizzer. :(

    if you know the name of the saver go to windows/system32 & rename the extention & see what that does. If it is no good rename it again.
     
  4. Baron_Flambe

    Baron_Flambe Guest

    Sorry, forgot to mention that it's running NT4 SP6. I meant to put that in the first post! :rolleyes:

    Did the pressing the winkey thing work in 9x or XP?
     
  5. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    It use to work in 9x. Just found this but again it is for xp.

    HKEY_USERS\.DEFAULT\Control Panel\Desktop. Value Name: ScreenSaveActive, Data Type: REG_SZ (String Value), Value Data: (0 = disabled, 1 =enabled). Change the value of 'ScreenSaveActive' to '0' to disable the screen saver. Restart Windows for the change to take effect. Note: Windows has a default screen saver called login.scr, which runs even if no screen saver has been selected.

    From kelly's corner.

    Might work on NT.
     
  6. Baron_Flambe

    Baron_Flambe Guest

    Unfortunately only administrator accounts can access the registry editor, and mine isn't. I've tried renaming the xxx.scr file to xxx.bak, so I'll leave it alone for a while and see what happens.
     
  7. JohnnyGreb

    JohnnyGreb Guest

    Maybe Windows Explorer: Go to C:\winnt\system32 and double click desk.cpl
    This might open it up, but most likely not.

    OR
    Maybe inport the value you want into the registry:

    save this as scrnsvr.reg:
    Code:
    REGEDIT4
    
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "ScreenSaveTimeOut"="300"
    
    The value is in seconds. The above as an example is 5 minutes. Set it to: 7200 (2 hours), 86400 (a day), or whatever.
    Once saved, double click to run. They may not have restricted access to this.
    One drawback with this one is you might have to do this whenever you logon, as I believe this key gets reset when you log off.

    Best of luck

    -JG
     
  8. Baron_Flambe

    Baron_Flambe Guest

    Thanks for your help guys. Both suggestions worked, renaming the screensaver stopped it from kicking in, and the registry code was successfully imported giving me a choice of two approaches.

    It sounds like a small thing, but when I'm monitoring a job it's a pain to have to keep re-entering my password every few minutes. Apparently it's a security feature, but as I work in a restricted access area it's just a pain in the arse.

    Thanks again.

    :happy:
     
  9. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Good stuff. Now get back to work. :D