Direct3D games restarting Windows XP

Discussion in 'Windows Desktop Systems' started by Nash, Oct 10, 2002.

  1. Nash

    Nash Guest

    I'm having a problem with Direct3D here. Any Direct3D game that I run restarts my computer in less than a minute after I start them. I've tried a clean install of XP and a newer driver for my video card. A blue screen appeared once with this:

    *** STOP: 0x0000008E (0xc0000005, 0xBFA0EAD8, 0xF5ED4A30, 0x00000000)

    *** nv4_disp.dll - ADDRESS BFA0EAD8 base at BF9B8000, DateStamp 3d3478e4

    My system:
    AMD Duron 700 Mhz
    Soyo K7VTA-PRO
    256 SDRAM Memory
    V7100(T) GeForce 2 MX 400 (TV-Out) video card

    If someone have any ideia of what is happening here please reply. Thanks.
     
  2. Kuja

    Kuja OSNN Addict

    Messages:
    163
    did you try dif. video drivers?
     
  3. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Unistall your current driver, let windows restart and let it install the standard nVidia drivers. Secondly install the newer (non-BETA) driver.
    Hope this helps.
     
  4. Nash

    Nash Guest

    I've tried three diferent drivers: the current one, one before the current and the newest beta, same problem. I've done what Glaanieboy said too, no solution.

    Sometimes my computer locks, sometimes it boots and sometimes it goes back to Windows. I've installed the SP1 update for XP, but the same thing happens.
     
  5. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Hmm... Are you using the DirectX 9 beta drivers?. If so revert back to 8.1 and try it again. If you are using DirectX 8.1 then do this:
    Press 'Start' -> 'Run' type in the box 'dxdiag' and press Enter. Go to the Display tab and click 'Test Direct3D'. If that doesn't work too, then I am afraid it might be a hardware issue.
     
  6. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    You could also try turning off the auto start. Right click my computer/properties/advanced/startup & recovery. Turn off auto restart. Now you should get an error message before it reboots.
     
  7. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    I know. Disable "AGP Fast Writes" in BIOS. Known GF2MX bug.
     
  8. Nash

    Nash Guest

    I'm using the DirectX 8.1 that comes with XP, I've already installed the update for it to 8.1b. The test for the Direct3D runs fine, and there's nothing wrong in the DirectX Files tab too.

    I've turned off the auto-start too, that's how I could see the error message.

    My BIOS do not have the "AGP fast writes" option, the only AGP options that's in it are:

    AGP Aperture Size : 64M
    AGP - 4X Mode : Enabled
    AGP Driving Control : Auto
    AGP Master 1 WS Write : Disabled
    AGP Master 1 WS Read : Disabled
     
  9. Rascal

    Rascal Guest

    could be a heat problem.....is everything cooooool?
     
  10. Nash

    Nash Guest

    I don't think that maybe it could be a heat problem, my CPU is at 40°C.
     
  11. jonocainuk

    jonocainuk Guest

    also do you use an ata100 controller card for your harddrive?

    I kept getting lockups on my pc with a similar STOP code (because it mentions the graphics driver im probably completely wrong... but it mentioned "try different graphics drivers" when I got the BSOD - was also using SP1 on XP. I've since ripped the ata100 card out (too problematic imo) and its runnin fine now)

    also... can u set the aperture rate a bit higher? say to 128?
     
  12. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Uh oh. I hope this doesn't mean that it's always on... The symptoms are exactly right for it. Does it say anything about "Infinate loop" for the driver?
     
  13. Nash

    Nash Guest

    jonocainuk:

    I don't have a ATA100 controller and I've tried to set the aperture size to 128, same thing happens.

    Zedric:

    There's nothing about infinite loops in the error messages.


    The strange is that I've already played many Direct3D games here without problems with the same system configuration. I think that the problem has begun when I've put a cable modem here, but it is connected to a NIC that was already working here before when I played the games, so I don't think that it is the problem.
     
  14. jonocainuk

    jonocainuk Guest

    if it happened since u got a cable modem, could it be possible that the connection rates on your games need changing? you might be flooding the games with packets or something causing it to crash?
     
  15. bossdodgers

    bossdodgers Guest

    Hi,

    I had exactly the same problem and the culprit is our good friend SP1 im afraid.
    I tried everything that has been suggested on this post and the only way i got it working in the end was by using the nvidia 40.72 drivers and applied the control panel fix.

    These drivers are still not yet signed though but it worked for me.

    When you install the SP1 you are supposed to uninstall all third party hardware and drivers and norton anti-virus before doing the update as problems may occur afterwards.

    I still wasnt happy with SP1 so i decided to do a re-install of xp and guess what, it still doesnt get rid of SP1 as some of the files remain and i spoke to microsoft and they confirmed everything that i am saying in this post.

    The only way to get rid of it totally is to re-format. The uninstall option you get when you download does not get rid of all the SP1 files and microsoft will be hopefully bringing out some bug fixes soon.

    Anyway try the 40.72 and dont forget the fix.It worked for me.
     
  16. Nash

    Nash Guest

    bossdodgers, where I can find this fix that you've talked about?
     
  17. bossdodgers

    bossdodgers Guest

    Here it is.

    Run it and follow the instructions exactly as they are from top to bottom.

    It removes the conflicting files that prevent the control panel working.

    And dont worry if you have already installed the drivers as it worked both ways for me.

    Dont worry about the fix being for 40.71 because it works for the 40.72 aswell.

    If you encounter any problems let me know
     
  18. Nash

    Nash Guest

    bossdodgers:
    I've tried the driver and the fix but the problem still happens. I've tried three times, two of them with a memory address error and one with a blue screen asking me to reboot with the following message:

    IRQL_NOT_LESS_OR_EQUAL

    I've got a utility to test Direct3D and it crashes the machine too.
     
  19. jonocainuk

    jonocainuk Guest

    try rebuilding the pc again... taking cables, cards and ram out the system... put them all back in and reinstall... that seems the last resort :/

    alternatively, move ur cards to another slot... i.e. NIC to a diff pci slot.
     
  20. djmorgan

    djmorgan OSNN Addict

    Messages:
    106
    This type of issue has been discussed at the Nforce MSI forum for some time now, it's been blamed upon the board and recent released drivers.

    However, those that experience this problem should straight after the crash activate XP's event viewer and check 'system' I think you'll find that you get a least 2 event messages and then at least 2 'Redbook' notices.

    With some of the K7N bios's these redbook advices have resulted in the monitor screen going black but everything working as though the computer was fine - just not working.

    An issue was reported some time ago where XP was doing it's job and verifying that all drivers were certified and making a report on those drivers that aren't certified, this was causing some nVidia vid drivers to lock up, there is no way to turn this function off in XP but it is known to cause crashes and other weird behavior.

    WHQ drivers seem the only way to prevent it - hope that helps somebody track down the error.

    :rolleyes: