did i fry my mobo??

Discussion in 'General Hardware' started by AmarSingh, Apr 26, 2002.

  1. AmarSingh

    AmarSingh Guest

    I have an old P120 sitting around that i never use, and i was messing around inside to take out a NIC and cdrom drive. when i was putting it back together i managed to drop a screw on the mobo. (ive done this before without problems). When i went to start the computer up to make sure it worked all i got was the fans came on, the other cdrom has power, but the hard drives are not turning on and the hard drive light is staying on. nothing esle happens. i tried messing around with the power cables to no avail. did i fry the mobo?? not a big deal if i did, just curious though.
     
  2. pc_tek

    pc_tek Guest

    boot to bios... make sure you do an EIDE auto detect to make sure everything is set right.

    make sure all jumpers are set right.

    All EIDE cable wires should have the red wire (#1 pin) closest to the power connection.

    reseat all AGP,PCI and ISA components.


    try that for starters!
     
  3. AmarSingh

    AmarSingh Guest

    well booting to the bios would have been my first guess if i got anything on the screen...it wont even POST
     
  4. dijital

    dijital Guest

    try switching you cables around. if that doesnt work, test the cables in another computer if you can so you can rule out the possibility of bad cabling.
     
  5. Device

    Device Guest

    I've dropped screws on the mobo and other card dozens of times without any damage done. Unless you were using an airplane screw, I don't think it would matter.

    I think the best way is, as mentioned before me, to just try the exponents in other systems.
     
  6. pc_tek

    pc_tek Guest

    Assuming you did everything in my first post (if not start there again)... then try this..

    Next, remove all hardware except for what is needed (Ex. Video and HD). remove everything else for now.

    bad hardware/mis-seated can cause the prob your having. check the pins for the agp, pci & isa slots on the mobo, make sure they are all in good shape. If you have other video card or hard drive, try putting those in it, just to see if it will boot.


    if it still does not boot with known good hardware:

    Reset the bios completely. You can do this a couple of ways.

    1. take battery out for an hour or two
    2. See MB manual, it may have a jumper that you can switch to clear the bios.


    If that doesnt help, you are getting very close to running out of options. I would find the motherboard info and find the right flash for bios and flash it. This probably seems wierd, but I have seen a case where as soon as you plugged a machine in, it would power up (yes without pushing power button), then hang on the POST. was wierd as hell, but the bios got corrupt somehow (would not even reset itself) and reflashing it fixed it. After i reflashed it when i plugged it in it no longer came on until power was pushed and booted normally.


    Good luck!

    for a plane ticket, ill gladly visit canada to fix it for free :D
     
  7. Device

    Device Guest

    Most bios with advanced power settings have the option to turn on the comp "always at powerloss". Then weh nyou put in the plugf it will boot.
     
  8. AmarSingh

    AmarSingh Guest

    thanks guys..ill see what i can do in a day or two...today im getting my new system so im gonna be busy with that all day installing all my apps and stuff.