Diablo 2 LoD error - Please help!

Discussion in 'PC Gaming' started by KatFisch, Feb 22, 2002.

  1. KatFisch

    KatFisch Guest

    Ive just gone to load up my D2 CD and I got this error (for the first ever time - I installed XP Pro a few weeks ago and have played it fine until now):
    Unable to load function: FT_Thunk (KERNEL32.dll) ...it says that the CD isnt in the drive(which is clearly IS) and it tells me to retry but just keeps giving me the same Error over and over.
    What the hell does this mean?!?! Please help
     
  2. DaEnigma

    DaEnigma Guest

    Sound like you may have tried to turn compatability on...

    Also make sure if your using fast user switching to D/L the SD2 patch for XP (updatesecdrv.exe)...
     
  3. Ci2e

    Ci2e XPert

    Messages:
    277
    No Video Modes Found

    I have played D2:LOD on this pc before with XP installed - I previously restarted and now it tells me there are no supported video modes found. If I don't play soon my characters will be deleted. If at all possible I would like to salvage my hard work.
     
  4. Gary Pandher

    Gary Pandher Moderator

    Messages:
    884
    Cire....give me ur username and password for D2:LOD and i'll go on em for a bit n make sure they dont get deleted....
    lol jus jokin...
    umm....i think this problem came up with someone else before in the forum's....
    y dont you just uninstall and install again...?:D
     
  5. KatFisch

    KatFisch Guest

    :eek:
    I actually realised what it was after posting this thread...Im such a dork! lol ...Two days ago I thought Id try switching on the compatibility for WinME(thats what I used to have on my PC before XP)...I didnt go to play D2 until today and forgot that I had switched it! D'oh!
    So, DaEnigma, you were right ;) Thanks all for replying though..Im glad it wasnt serious because I needed to check my Fiances mule accounts to make sure that they hadnt been deleted after a supposed "3 months of non-use".

    The Dork thanks you .... :D

    Katherine
     
  6. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    Cire, try removing your GC drivers and reinstalling... you never know, or even reinstalling Diablo2 completely.
     
  7. Ci2e

    Ci2e XPert

    Messages:
    277
    Uninstall = No Cure

    I just un-installed and re-installed and no luck. I am really clueless here- I am thinking that b/c I have the 27.42 det's that since they are not official they may not be pointing out my vid card significantly as the officials.

    Here is a pic:
    [​IMG]
     
  8. JeremyT

    JeremyT Guest

    I have a Riva TnT2 and d/l the 23.11 drivers. XP wouldn't even start after that. Then I used 27.42 and XP started fine, but D2:LoD wouldn't start. When I did the Video test it would lock up on the Direct Draw test. So I just went back to the drivers that Microsoft shipped with XP and everything works fine. Even get 60FPS in UT.
     
  9. Ci2e

    Ci2e XPert

    Messages:
    277
    w00t

    JeremyT: that worked; although now since im using old drivers the Nascar 2002 menu really lags with the mouse overs. The only thing I can think of to fix that is update the drivers. I guess I'm going to have to give up on Diablo 2 until Diablo 3 comes out...