Device Driver Problem, Which one?

Discussion in 'Windows Desktop Systems' started by joshuajme, Oct 9, 2002.

  1. joshuajme

    joshuajme Guest

    I am getting a bsod at random times and all my games are crashing constantly, namely soldier of fortune 2. Most of the time the game just closes down but it sometimes gives me the bsod with 0x0000008E (device driver) or just freezes altoghether and doesnt even go blue on me. I have tried re installing the game to.

    No driver is identified on the screen. The game is splurting out the following errors in the error log;

    Faulting application sof2mp.exe, version 0.0.0.0, faulting module sof2mp.exe, version 0.0.0.0, fault address 0x000b068c

    Faulting application sof2mp.exe, version 0.0.0.0, faulting module unknown, version 0.0.0.0, fault address 0x04abb547.

    Faulting application sof2mp.exe, version 0.0.0.0, faulting module unknown, version 0.0.0.0, fault address 0x01a8fc44.

    The application, C:\Program Files\Soldier of Fortune II - Double Helix\SoF2MP.exe, generated an application error The error occurred on 10/07/2002 @ 23:59:12.156 The exception generated was c0000005 at address 0048A3FF (SoF2MP)

    But this error is coming up out of games to. At first i thought it was the sound so i re installed the drivers and tried newer drivers, tried disabling the device all together and the game and os are still crashing.
    Graphics wise I have tried the latest beta xp 40.72 and the 30.82 ones which have no affect on the crashing. There is no current BIOS updates either. The report from microsoft is as follows:

    http://oca.microsoft.com/en/Response.asp?SID=77

    Any1 have any ideas on how to find the driver in question?

    Sys specs;
    Gigabyte 7VAXP KT 400
    AMD XP1800
    TT Volcano 9
    512 mb PC3200
    2x 40gb Maxtor on Promise 20276 RAID 0
    GF4 Ti4600 Asus Deluxe
    SB Audigy Player
    DVD/CDRW .........
     
  2. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    I would update all your drivers...can't go wrong there, and it might help
     
  3. joshuajme

    joshuajme Guest

    Already tried that a million times........
     
  4. iowaboy

    iowaboy old person

    Messages:
    118
    Location:
    Iowa, USA
    go to google and search for sof2.exe. I found that there is a patch for the problems that you are having by searching on google. It is a problem with soldier of fortune 2.
     
  5. joshuajme

    joshuajme Guest

    Ok its not going to help suggesting getting patches, every device has the latest driver available. Including sof2, which is on ver 1.02. Any other ideas?