Connecting to my FTP problem.

Discussion in 'Windows Desktop Systems' started by Heeter, Sep 11, 2004.

  1. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Hi Guys,

    A problem has arisen with connecting to my personal FTP server. I use BulletProof. In the last three days or so, no one has been able to login to my Server. I am able to get in within my home into that tower, but no one from outside. WinXPPro SP2 firewall has always been turned off. I tried disabling my third party firewall, to no avail. I have reset, rebooted and re-forwarded the ports on the router, nothing still. I have uninstalled, and reinstalled my DNS Resolver (I use No-IP), nothing still. The person trying to get in has a Winsock error come up on their login screen. On my end, I only see them disconnecting on my Bulletproof log screen.

    Like I said, It just stopped working three days ago. It was working fine before that. Nothing was installed. Tower is a dedicated FTP Server.

    Any Ideas?

    Thanks in advance,

    Heeter
     
  2. Xie

    Xie - geek - Subscribed User Folding Team

    Messages:
    5,275
    Location:
    NY, USA
    Perhaps your ISP is not liking you running an FTP server? (just a long shot) Also what kind of winsock error? What are they using as an FTP client? Have they changed clients? Is it just one person or is it everyone?
     
  3. E-kLiPsE

    E-kLiPsE OSNN Junkie

    Messages:
    37
    Location:
    Hamilton, Ontario
    (Not Related)
    @Xie - what's the name of that crazy scientist dude from ATHF?
     
  4. zeke_mo

    zeke_mo (value not set) Staff Member Political User Folding Team

    Messages:
    1,984
    Location:
    Placerville, CA
    I dont know about the Dr., I know the one from sealab is Dr. Quin(however its spelled)

    Try using FileZilla, I use it and its fast and easy
     
  5. ThePatriot

    ThePatriot -=[BOHICA!]=- Political User

    Messages:
    1,742
    Location:
    Pennsylvania
    I agree...you could try changing the default port in Bulletproof to rule out the isp blocking ftp.
     
  6. Xie

    Xie - geek - Subscribed User Folding Team

    Messages:
    5,275
    Location:
    NY, USA
    Dr. Weird ;)
     
  7. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Thanks for the input,

    I will test the default port change.


    Heeter
     
  8. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Hi Guys,

    I changed my default port# from 21 to 25, for testing purposes. Forwarded the port on the router, still same problem. When Someone tries to connect, the actually connection hangs, until the person disconnects. The disconnect command does show up on my Bulletproof log. No Winsock errors came up on my friend's FTP client during test this time.

    Any other Ideas? Thanks for all the help so far.

    Heeter
     
  9. Xie

    Xie - geek - Subscribed User Folding Team

    Messages:
    5,275
    Location:
    NY, USA
    I would try a port besides 25 as that email default I believe and your ISP might block that as well, keeping you from running your own email server as some people have them compromised and then all spammy hell breaks loose. ;)
     
  10. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Yeah, 25 was sort of a bad choice. ;) Try something above 1024, like 2100 or whatever.
     
  11. PseudoKiller

    PseudoKiller Zug Zug

    Messages:
    3,858
    Location:
    Ice Crown Citadel
    everyone who tries to connect to your ftp cannot get in or is it one person??

    PM me your IP and let me see if I can get in.
     
  12. Xie

    Xie - geek - Subscribed User Folding Team

    Messages:
    5,275
    Location:
    NY, USA
    Also what client does your friend use? Maybe something misconfigured on there end?
     
  13. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    Depending on what router you are using, Unless you have dmz enabled for your dedicated server, you will only be able to use port 21. Check no ip and see if it updated your ip. If it hasn't update it .. That is normal cause ..

    and also when you forward the ports in your router you have to open 20 and 21 .. Another thing to is to check to see if your passive port range is opened up.
     
  14. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Hi Guys,

    It was actually my ISP. I changed to Port 2121, and lo and behold, we have a logon.
    I also did phone my ISP concerned about them locking up that port 21. They told me that 21 has always been locked and they trying to figure out how I was able to use it. I think that maybe mistakingly a business account was setup. Who knows. They also told me that they just do not up and lock a port on someone, without first warning the person.

    Thanks for all your help, everyone.

    Heeter
     
  15. ThePatriot

    ThePatriot -=[BOHICA!]=- Political User

    Messages:
    1,742
    Location:
    Pennsylvania
    Glad you got it straightened out! ISP's are kinda fishy sometimes. A local one here started blocking TFTP on us without warning. They lost 6 business accounts because it is a mission critical service that we cant do without, at least for the near future.
     
  16. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Well that's not true at all. You can use any port you want as long as you also specify a passive range to use. As long as the router can forward ports, it will work. Port 20 isn't used nowadays.
     
  17. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    Everyone I have set up has been like that.. Trying to use other ports besides 21 didn't work, this is even with passive ranges set up. You have to use 20 for the data transfer and 21 for control .. I also had to foward the passive port range. Enabling dmz made it possible to use any port.

    I used G6 Ftp Server, Serv-U Ftp Server, Bulletproof Ftp Server, Ect. It did the same thing with each one. This is with a Netgear and Linksys router mind you.

    If you are able to do it then congratulations I am proud of you .. What router and server are you using by the way ???
     
  18. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Those precise servers plus RaidenFTPd or Filezilla server using a D-Link router, Netgear router or a Linux firewall. I've never used a Linksys router though, but FTP shouldn't be any different from any other server software. Forward the ports it uses and it will work. The passive range is instead of port 20. You must also specify the passive range in the server. Unless you have some other firewall in the way somewhere it will work if set up correctly.
     
  19. fitz

    fitz Just Floating Along Staff Member Political User Folding Team

    Messages:
    4,076
    Location:
    Chicagoland
    Actually, port 20 is still the default port according to the RFC (http://www.faqs.org/rfcs/rfc959.html). Unless the end user sets up his client to specifically use the PASV mode command, port 20 is still required.

    FTP is bane protocol of all firewalls.

    --fitz
     
  20. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Yes, port 20 is in the rfc, but I've never seen a modern client acctually use it. Maybe I've just missed it, but by default most clients are set to use PASV mode, so if you set the server up to use PASV, it works in most cases without any fuss on the client's side.