CMD path error

Discussion in 'Windows Desktop Systems' started by lieb39, May 4, 2003.

  1. lieb39

    lieb39 Apple lover, PC User

    Messages:
    526
    Location:
    Australia
    Hello.

    I'm running Windows XP Pro. Everytime I go into command prompt (cmd, NOT command) and try any command that isn't based in the current directory (netstat, net login, ping, ftp, etc.) It gives me a error saying the command can not be found. Than when I type in " path " i get:
    PATH=%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\Executive Software\DiskeeperWorkstation\;C:\PROGRA~1\COMMON~1\ULEADS~1\MPEG

    Than I have a choice: go to the c:\windows\system32\ directory to preform the task I want or type "path=c:\windows\system32\" to change the path, and it will fix the error.

    How can I fix this error without having to change my currently directory or change the path everytime i open cmd?

    Thanks,

    lieb39
     
  2. zyfos

    zyfos Resurrected

    Messages:
    236
    At the command prompt, type
    cd %SystemRoot%
    and see where it takes you. If it's something besides C:\Windows, then that's probably your problem. Check your windir command in System Properties -> Advanced tab -> Environment Variables.
     
  3. TuMbRaS

    TuMbRaS Guest

    CMD path.......

    Hiya~ :)

    I am also running WIN XP Pro. While in the "Environmental Variables" page within the Advanced tab... you will want to check your "Path", "PATHEXT", and "ComSpec" fields under the "System Variables" window. To do this, highlight the "Path" field and then click on "Edit". In the "Variable Value" field, it should look something similar to this:

    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem

    at a minimum, you should have that listed in there... probably having your video card info somewhere following the "\Wbem.." entry at the end.

    In addition to the Path being reset, you will want to make sure you have the following set in your "Pathext" field:


    .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH

    and finally, in your "ComSpec" field, make sure you have something similar to this:


    %SystemRoot%\system32\cmd.exe

    and that should do it. I have had this happen on a few machines at work..and the settings above have proven to work each and every time.

    If you have any other questions, don't hesitate to get in touch with me..(yahoo messenger or email)

    Sincerely,
    ~n
    :D
     
  4. lieb39

    lieb39 Apple lover, PC User

    Messages:
    526
    Location:
    Australia
    I fixed it. I didn't know about system variables, so I just went in there and changed the path variable, just adding;
    to the end.

    Thanks!