change keyboard layout at login screen

Discussion in 'Windows Desktop Systems' started by Swi, Jan 28, 2004.

  1. Swi

    Swi gningnegneur

    Messages:
    302
    Location:
    Montreal
    Hi!
    I have set my keyboard layout to a "qwerty" mode in my account but at the login screen, it is in azerty mode (Francais france: the default for this version of windows). Is there a way to set it to a qwerty layout (in that case, french canada) effective at the login screen?
    (config file to set or else)

    Thx!
    Swi
     
  2. Howling Wolf

    Howling Wolf We did not deserve this !

    Messages:
    1,243
    Location:
    Amongst the Native Ones
    Do you have the Fr logo sitting in the taskbar ? If yes, go into properties, it corresponds to Regional Settings in control panel, there what keyboard layout do you have ? Fr, Fr-canadian ? From there, add the right keyboard and del the Fr (which is mine actually ;) )
    But I think this is an option you set during install...
    Hope this helps you... ;)
     
  3. yoyo

    yoyo _________________

    Messages:
    1,557
    As far as I know you would have to change this in the registry under

    HKEY_USERS\.DEFAULT\Keyboard Layout\Preload

    Change the value for 1 to the same value you have at

    HKEY_CURRENT_USER\Keyboard Layout\Preload

    Should be 00000c0c for French (Canada) but better look what you've got there.
     
  4. Swi

    Swi gningnegneur

    Messages:
    302
    Location:
    Montreal
    It works! thanks!


    Howling Wolf, the problem was before I could login, so the taskbar wasn't there yet, thanks anyway!


    Swi