Certain Websites not Loading on Client Computers

Discussion in 'Windows Desktop Systems' started by SuDs, Jan 5, 2002.

  1. SuDs

    SuDs Guest

    Hi,

    I'm running 3 computers, the one i'm using is the host while the other's are the clients.

    the problem is that i can't access certain websites,( ie. www.xp-erience.org, www.candystand.com.) on the client computers.

    not too sure what i did wrong but i used the network setup wizard.

    any help would be of assistance.

    thanks.
     
  2. JJB6486

    JJB6486 Retired Mod Political User

    Messages:
    1,207
    Location:
    West Lafayette, IN, USA
    But some sites are accessile, right? It sounds like a problem with your ISP's DNS servers. Set your client's DNS servers to the the actual server IPs, rather than the IP of the gateway.

    JJB6486
     
  3. MiseryQ

    MiseryQ Guest

    Is the server running Xp?!?

    Try running "ipconfig /all" at a command prompt on the server and using the DNS entries on the client computers...

    If that does'nt work I have a drastic fix...
     
  4. SuDs

    SuDs Guest


    yes, the server is running XP professional,
    2 other clients are using XP home and win98.
    Both computers have the same problems with accessing certain websites while other websites work completely fine.
    ...also sometimes it has trouble downloading files from websites.

    how do you enter DNS entries on the client computers?
    and what is your drastic fix?
     
  5. JJB6486

    JJB6486 Retired Mod Political User

    Messages:
    1,207
    Location:
    West Lafayette, IN, USA
    For the DNS servers:

    On XP:
    Open up the properties of your network connection, and from that window, open properties for the TCP/IP Protocol. Click the togle button "Use the following DNS server addresses." Enter ther two IPs that are in the NIC card on the INTERNET side of the host machine. Click OK to all dialogs.

    ON 98:
    Open up the Network Control Panel. Find TCP/IP->Your NIC Card. Open the properties for it. Click the DNS tab. Check the toggle button "Enable DNS." For hostname and domain, just enter the comptuer's network name and a "*" respectively. Under "Domain Name Search Order, click add. Enter ther first IP that is in the NIC card on the INTERNET side of the host machine. Click "add" again and repeat the process for the 2nd DNS IP. Click OK to all dialogs.

    JJB6486
     
  6. MiseryQ

    MiseryQ Guest

    I had a long detailed explanation, but I got beat to it... My connection got dropped(?!?), then the forums went down(?!?). Since I copied it earlier from the post:

    "If this is a little patronizing forgive me. I'm not sure how much detail to give, even though you got through the hard part...

    On the "server" go to the start menu > "run"...

    Type cmd then ipconfig /all ...

    The last adapter listed should be your broadband, I assume your using it, if not disregard this whole thing. Where it says "DNS Servers", write these down...

    On your Clients... Right click "network properties"... Right click your network adapter and go to properties... Highlight "internet Protocol (TCP/IP)" then the properties button... Click the Advanced button... DNS tab... Then the "add" button and add the DNS entries you copied from the server...

    MY server and some others I've seen are set up as "root" and won't foward DNS requests... I hope I'm using the right terms, I'm rather new at this networking stuff.

    The drastic measure is, are you using nat?, to get this driver and use it instead of the built in Xp client... I used Xp.Net and had the same problem... Took me awhile to figure this out...
     
  7. SuDs

    SuDs Guest

    help me some more!!! please. i beg of you. :(
     
  8. Deszaras

    Deszaras Guest

    You may need to lower the MTU on both 98 machines. I had the same problem before with a 98 machine on an XP network.
     
  9. Dubbin1

    Dubbin1 I Like Cheese

    Messages:
    744
    Location:
    Ohio
    I forget where I found this but it fix the problem for me.

    Can't access some websites while using a shared PPPoE connection

    Intended For
    Windows XP
    Windows 2000
    Windows Me
    Windows 98

    If you're using Windows' built-in support for Internet Connection Sharing, and your Internet connection is facilitated by PPPoE software (such as Enternet 300) or Windows XP's built-in PPPoE, you may experience this problem. Although any web site will be accessible on the "Host" computer, certain web sites will never load successfully from any of the "client" machines. (If you don't know what "Hosts" or "Clients" are with regard to ICS, read Internet Connection Sharing.) The problem is caused by an incompatible MTU networking setting: Windows' default is 1500, but PPPoE uses 1492 or 1454. Here's how to fix it:

    Find the IP address of your gateway. If you're using Windows 2000 or XP, run IPCONFIG at a command prompt on the Host computer. If you're using Windows 98 or Me, run WINIPCFG on the Host computer. Either way, you'll get an address that looks like xxx.xxx.xxx.xxx (where the x's represent numbers).
    Then, go to one of your Client machines, and type the following:
    PING -f -l 1500 xxx.xxx.xxx.xxx
    (where xxx.xxx.xxx.xxx is the gateway address you obtained in the first step). You'll probably get an error message indicating that it must be fragmented. If you do, type the following:
    PING -f -l 1492 xxx.xxx.xxx.xxx
    If that doesn't work, try this:
    PING -f -l 1454 xxx.xxx.xxx.xxx
    The numbers in each of these examples (1500, 1492, 1454) are the MTU values. Continue issuing this command with lower and lower MTU numbers until you get ping responses instead of an error message. The highest MTU value that works is the one you need to be using. If an MTU of 1500 (the first command, above) does not produce an error, then this solution won't work for you.
    The next step is to configure all your Client computers to use the new, lower MTU as the default for all Internet communication.
    Windows 2000 and XP:

    Run the Registry Editor (REGEDIT.EXE) on one of your "Client" machines.
    Navigate to HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters\ Interfaces.
    There should be several subkeys under the Interfaces key; most likely, you'll find three. View the contents of each key by clicking, and find the one that corresponds to your primary network adapter; it will be the one with more values than the other two, and will have an IP address value set to something like 192.168.0.x.
    Once you've found the correct subkey, create a new DWORD value in it (Edit -> New -> DWORD Value), and name the value MTU.
    Double-click the new value, choose the Decimal option, and type the MTU value determined above.
    Click Ok when you're done - you'll need to restart Windows for this change take effect.
    Repeat this for each Client machine.
    Windows 98/Me:

    Run the Registry Editor (REGEDIT.EXE) on one of your "Client" machines.
    Navigate to HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Class\ Nettrans\.
    Under that branch, find a key (numbered, such as 0005) that contains has TCP/IP assigned to the DriverDesc value.
    Select New from the Edit menu, then String Value, and type MaxMTU for the name of the new value.
    Double-click the new value, choose the Decimal option, and type the MTU value determined above(mine is 1454).
    Click Ok when you're done - you'll need to restart Windows for this change take effect.
    Repeat this for each Client machine.
     
  10. SuDs

    SuDs Guest

    thank you so much, that fixed my problem!

    much appreciated!
     
  11. lhhood423

    lhhood423 Guest

    I also owe you

    I also had the same problem and owe you a huge thankyou thanks very much!!!!!!!!!!!!