CD’s are not auto running.

Discussion in 'Windows Desktop Systems' started by geoffwm, Dec 7, 2002.

  1. geoffwm

    geoffwm Guest

    OS Windows XP Pro:

    When I insert a CD with an autorun.inf file in the root of the CD the startup program does not initiate.
    Could anyone please let me know how to turn this autorun feature back on?

    Many thanks,
  2. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Melbourne Australia
    Back up the registry first.
    This has a little bit in it on how to get it back on using the registry.
    Turn Off Autoplay For CDs

    Click Start , click Run , type regedit in the Open box, and then press ENTER.
    Locate and click the following registry key:
    -To disable automatically running CD-ROMs, change the Autorun value to 0 (zero).
    -To enable automatically running CD-ROMs, change the Autorun value to 1.
    Restart your computer.
    (NOTE : This method disables automatically running CD-ROMs.
    If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.

    See how that goes. If not change it back.
  3. geoffwm

    geoffwm Guest


    Thanks for the tip "Hipster" much appreciated.

  4. koko

    koko Got Root?

    Columbia, S.C.
    or you could just do it the easy and right click on your cd-drive in my computer.

    turn autoplay back on there! ;)
  5. maz4ruth

    maz4ruth Guest

    Note: I tried the above and it didn't work...

    But then I noticed a key inside the registry called "AutorunAlwaysOff" - or something like that.

    I just deleted that and it fixed the problem.

    Previously when I inserted a disc, the drive did not respond at all. It did not show the Icon or the Volume Label inside my computer.

    But it seems to be ok now :)