CDROM refresh

Discussion in 'Windows Desktop Systems' started by Maddog, Jan 7, 2002.

  1. Maddog

    Maddog Guest

    Can anyone help,if I put a cd in my cdrom it reads it fine problem is when I put another 1 in it reads it as the previous cd,contents as well,even if I refresh in Windows Explorer.
    I cannot load games that have more then 1cd.
    I can get away with putting the 2nd cd in my cd writer and browsing to load it.
    If I reboot I can read another cd
    regards Chris:)
  2. Qumahlin

    Qumahlin Moderator

    really? have you tried going into my computer and hitting refresh on that screen from there?

    a last shot way is open explorer, right click on the drive hit properties and see if the colume label is correct for what cd is in...or when in properties goto the cd drive..then props again..then volumes, then hit populate...if that does not work..I have no idea what to try

    hope it works man
  3. Akash

    Akash OSNN Senior Addict

    if not
    remove the device from devcie manager and let it re-read it on reboot
  4. westy1

    westy1 Guest

    Has this just started, or have you just installed it.
    What are the makes or your drives.
  5. Maddog

    Maddog Guest

    Sorry for the delay, as I have been busy decorating
    I have an Acer CDRW 4X4X32 & a Max 52speed CDROM,
    I have only just installed XP PRO on my system
  6. westy1

    westy1 Guest

  7. nwilcox

    nwilcox Guest

    ACER 56X wont refresh

    I am having same problem. ACER 56X (656-A) Have tried all suggestions posted. My thought is that it is not XP Ready, like it says that it is on box.
  8. kesjeff

    kesjeff Guest

    Same Problem

    I also have a Acer CD-656A drive and I get the same thing when one cd is in it reads fine but when I change the cd the contents don't change it still thinks its the old cd. I have tried refresh and all that stuff.
  9. robin.munro

    robin.munro Guest

    I have a TEAC...

    I have a TEAC CD-W516EB and it has always done that... not refresh.....

  10. kesjeff

    kesjeff Guest

    Acer CD-656A Drive

    I talked with Acer tech support and they told me to update the firmware. There new site is at and download it here. She said that if that doesn't fix it nothing will and she said that there is many CDrom's out there that says they work with XP but have some issues with XP.
  11. kesjeff

    kesjeff Guest

    I didn't get the drive to work!

    I had the Acer CD-656A drive in my computer with Windows XP it did the same thing not releasing the old contents of the drive I talked to acer and they said to try to update the firmware. Did that but nothing changed thay said that XP is touchy with CDrom's so I took out that drive and put a different one in and works alot better.
  12. stapler101

    stapler101 Guest

    I can tell you the prevention, but not the cure.
    go to my computer, right click on the cd drive and select eject. This will eject the cd and refresh the drive.
  13. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    I had a version of this problem. The drive, in fact 2, didn't refresh which disk was in it. however you could run the disk and look at its contents, it just said it was the first disk you put in.

    As i said, not the same but i thought the same solution was at least worth a try, since it hasn't been fixed yet

    run redgeidt
    Locate and click the following registry key:

    locate the Autorun value and change the value to 1.
  14. Otter21

    Otter21 Guest

    I had this problem today with my Ricoh CDR/DVD and I ran Win Doctor (Norton Systemworks) and it fixed it straight away.
    If you know someone who has Sysemworks you can run it without installing it.
    Hope it helps.
  15. nwilcox

    nwilcox Guest

    mine CDROM works now but

    I updated my VIA VIA Miniport and IDE Filter drivers. CD-ROM works now but... - When ever I attempt to Delete/Move/Change Properties of an icon, the system goes to the infamous "Error Report" mode and wants to send the same thing over and over to MS to which they never respond anyway... I've checked all the knowledge bases and do not have any of the "Offending" programs known to cause this problem on my system, yet I
    continually have this problem which is starting to drive me crazy!
    Seems to have started after installed VIA Miniport and IDE Filter drivers. But I need them for CD-ROM to work correctly. Any Clues

    Home Edition
    VIA Controllers
  16. Flash

    Flash Guest

    As I have indicated a few times and don't mean to repeat myself, but by changing my CD drive letter from D: to F: fixed my refresh, update probelms, etc.
  17. cheezzzz

    cheezzzz Guest's what I do to rectify the situation. When done with the first cd, insert another, hit back button, then click on the cd drive. Works for me. Hope this helps.

  18. mac123

    mac123 Guest

    I had a problem like that.
    My cd-rw and the dvd-rom didn't refresh the name of the cd, but i could access the cd and run it manualy.

    I solve the refresh by uninstaling some burning software(Fireburner).

    Maybe some of the burning soft that you have is making that problem, try to uninstall your burning soft one by one to see which is doing that problem.

    Hope this helps.

    Good luck. :cool:
  19. trebor271075

    trebor271075 Guest

    From my experience I have ALWAYS managed to track this effect down to the IDE bus master drivers! Try turning off DMA mode see if this helps....

    I actually had the exact same thing happen to me on windows 95 about 6 years ago!!!!!!

    It is currently haunting me too.. I am goign to updte my via 4in1 drivers tongiht to see if this cures the problem.. Although my effect is much much less... My cdrom icon in My Computer remains set to the 1st cd-rom to be in the drive, but the contents and everything else updates fine as I swap discs! A minor annoyance!
  20. i have also seen this on many computers i have built i only use acer drives as its the only one ive never had any go bad.

    seems to be a little quirk in xp