CD/DVD Update Problem?

Discussion in 'General Hardware' started by Bablos, Dec 23, 2002.

  1. Bablos

    Bablos Guest

    Hi There...

    I'm doing a fresh XP install on one of my machines, and I've come across an odd problem;

    Whenever I take a CD or DVD out of their appropriate drives, the name stays next to the drive. If I put another CD or DVD into the drives, it still doesn't change - the only time the system updates the names is at reboot.

    As a result, my system always shows the two disks that were in the drives at boot up.

    Anyone know what the problem is? I've had a search around, and the problem has occurred before, but no one has replied to the problem.

    Hope someone can help!

  2. Burpster

    Burpster Guest

    on my old system PII that used to happen...but with new sys. it updates very quickly when changing CD's or DVD's
  3. Bablos

    Bablos Guest

    Hi There...

    It used to be fine, but it's playing up all of a sudden. Anyone know how I can resolve the problem?

  4. ditchhopper

    ditchhopper OSNN Addict

    I had the exact same thing happen to me. Never had the patience to track down the problem so I did a reinstall and used the repair option. Been workin fine since. Some things to try though: Try to right click and refresh the page. Didnt work for me but you never know. Go to control panel/Administrative tools/component services/services and check that "Imapi CD Burning Com Service" is set to manual. "Removable storage" is set to Auto. And "Shell hardware detection" is set to Auto. I dont know that thatll fix anything but its all I can think of now.
  5. Bablos

    Bablos Guest

    Hi There...

    It's solved - I managed to track it down by going through the numerous restore points that a new install tends to create!

    I use a program called System Mechanic, and it can set various system options, one of which says 'Automatically start data CDROMs when they are inserted' - I naturally related this to autoplay, and switched it off, but this is what was causing the problem.

    Thanks anyway!