Can't Record Sound

Discussion in 'General Hardware' started by Bman, Nov 20, 2008.

  1. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    So I have been for awhile trying to record sound along with my videos.

    The only way I can get any sound (any its very quite) is through my mic.

    I have onboard sound with the EVGA 780i SLI motherboard. I should be able to record sound correct? Am I doing something wrong, or whats the problem?


    And sorta side question, but related. In the attached image, what setting should I be on?
     
    Last edited: Aug 4, 2009
  2. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    I have also recently been having sound issues in games. Out of no where.

    Basically the voices fade in and out, and fade from one area to another, if I move around i can hear a guy, if i go away from him i cant. I dont understand whats wrong.
     
  3. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    First post. Select the sound quality best matching your game playback setting (look in the audio setup menus).

    On the second post. It is unclear if you are you loosing the canned palyer voice overs or are you loosing team chat sound. If you move away from or turn away froma speaking player the game may intentionally drop you out of "hearing range" since you don't want to hear someone on the other side of the map.

    If it is team chat you are loosing that should not be happening unless they have added some really realistic effects to the newer games. Some games block player chat with dead players for realism so they can't give away tactical info.

    Are you using a game record feature to capture the game for playback or are you suing an external program?
     
  4. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    The voices that I am losing are in game, not team chat nor chat. It's like CODW@W and a few other games I have noticed, its like I face the guy i need to talk too and there is no sound coming from him but he is talking, i turn to the left and I can hear him, to the right and i sorta hear him. Its different for each character in a game.

    And if I am suppose to select the sound quality best matching my game playback, I play over 100 different games, so how am I suppose to choose? Or know whats best.

    In terms of recording, I mostly use Xfire to record video (which records sound as well) And the above issue is not related to recording. Just thought Id put the similar issues together in the same thread.

    *edit I have also noticed that desktop sound and application sound is very different, some things are much louder or quieter then others. ARG
     
    Last edited: Nov 21, 2008
  5. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    So I guess no one has any ideas.

    I made the thread confusing I guess. My issues are these.

    1. Can't record sound when recording video (normally use Xfire)
    2. Sound is distorded and different levels in game and out of game, echoes and other. Mainly voices are lower and out of hearing then other sound effects and music.

    I have onboard sound with the 780i SLI EVGA Motherboard.
     
    Last edited: Dec 7, 2008
  6. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    Anyone? Really, Google ain't helping me either, it's hard to search for this topic.
     
  7. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    For recording make sure Mic Boost is on when using a microphone.

    Also make sure the sound control sliders are all set to the same level (wave, SW Synth, Mic, etc). I have seen the slider bars get changed y applications and I have to reset them. Also note there are two pages of sliders, one for record and the other for playback. Make sure you set them all. Make sure none of the sliders on the record page are set to Mute.

    Set sliders for about 2/3 of the way up on the slider bar. I have had MBs where they distort badly if the sliders are set too high.

    Check the website for whoever makes the sound chips for their latest drivers. TheMKB makers usually lag behind on postign updates. Make sure you get the ones for the correct sound chipset.

    If none of that works it could be the MB or the video card. They started piping the sound though the MB PCI channels a few years instead of rear panel jumpers and that has created "issues" that could cause breakup or distortion. Use the lowest sound quality setting you can find for the various games as a test.
     
    tdinc likes this.
  8. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    So I couldn't figure out my sound issue.

    So I uninstalled the drivers and device from Device Manager, rebooted and let windows install its own drivers, looked into the settings. And the first post, the image I show it is now at 16bit and everything is working 100% the way it should. Which is weird, this motherboard is new and I thought default would of been at least 24bit or something.

    Glad its fixed, can't wait to get better quality sound lol
     
  9. RonStarusnak

    RonStarusnak OSNN Addict

    Messages:
    51
    Some games do that. Especially Steam games, it's also directional. If you're having a problem recording your sound try recording it separately from your video with a different program.
     
  10. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    I believe its just my onboard sound card. And recording it separately is a pain in the butt, more work in the long run. But thanks.
     
  11. epk

    epk Moderator Political User Folding Team

    Messages:
    1,241
    Location:
    Buenos Aires
    if u're using an onboard soundcard, check that eax isnt activated in-game (maybe with windows drivers its not supported and thats why now it works ok)

    eax support on integrated solutions is really lousy, i know it first hand
     
    Bman likes this.
  12. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    i get that with my 680i board - asus drivers are crap - ones from ms are better - which is a strange thing for me to say
     
  13. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    Alright next time I record, I will make sure EAX is not on. Thanks.
     
  14. epk

    epk Moderator Political User Folding Team

    Messages:
    1,241
    Location:
    Buenos Aires
    careful with the crusader tux on ur avatar after that post :D
     
  15. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    one of my better avatars i feel :)
     
  16. falconguard

    falconguard Carbon based lifeform Political User Folding Team

    Messages:
    3,406
    Location:
    SoCal
    I thought it was a cyclopean crusader tux.