cant install directx 9 in XP

Discussion in 'Windows Desktop Systems' started by ruby lane, Feb 2, 2003.

  1. ruby lane

    ruby lane Guest

    I cannot install the final release of Directx 9.0 on Windows XP. An error message pops up saying that "this program hasn't passed the windows logo test" - no go (and i MEAN no go) from that point. I'm beta testing a game that requires dx9 and would appreciate any help.
    (yes, i'm an admin on the machine, yes, i do have all possible windows installer policies set in group policies, all updates, service packs, drivers, crypto service running, AND no, i didn't see that happening before)

    thanks for input
  2. melon

    melon MS-DOS 2.0 Political User

    Have you tried both DX 9 runtime (small installer; only downloads what is needed) and the DX 9 redist (the whole thing)?

    Maybe one or the other will work better. I don't know...just a thought.

  3. ruby lane

    ruby lane Guest

    yes i did try both, the 30 meg package as well as web installer. they both end up with the same error.

    well, i heard of two, maybe three people on earth having this problem, and no solution whatsoever... i really hope it's not that exotic.
  4. ruby lane

    ruby lane Guest

    nope, not that. it's been set to ignore for ages now... :((

    i'm desperate
  5. ElementalDragon

    ElementalDragon The One and Only

    Lehighton, PA
    probably a stupid question, but i figured why not ask. Did you install SP1 yet? i have no trouble when installing DX9.

    BTW, what game are you testing that uses DX9?
  6. ruby lane

    ruby lane Guest

    i might have just figured it out...

    i should have checked my logs earlier... like setupapi.log
    or DirectX.log, or event viewer. well, it seems i was receiving lots of ESENT errors:

    Catalog Database (804) Unable to read the header of logfile C:\WINDOWS\System32\CatRoot2\edb00001.log. Error -530.
    event ID 412

    I googled for ESENT and came up with this:;en-us;q278316

    well I was too tired to try this, besides it's closely related, but not exact - error ID might be the same, but the log header's not, so I just renamed ..\System32\CatRoot2\edb00001.log to XYZ_edb00001.log and ran dx9 install. guess what, it worked.

    i really don't know if it's that simple, or if it didn't screw up something else. fact is, dx9 now wants me to reset. i hope i see you guys tomorrow :)
  7. ruby lane

    ruby lane Guest

    ElementalD: er.. yes, Ive got XP SP1 release :) the game in mention is EVE The Second Genesism check it out, it's awesome - if ur into space stuff :)

    Enyo: I couldnt find any reference to that problem (xcept 1) either, it seemed strange, must be rare. thank you for input, as you can see, i managed to overcome this magic thing, but you're right about LOGS, damn, I'll try to remember to check my logs first. This is what happens when things go smooth, you forget ;)

    now i reset. will see what happens. g-nite.