Cant get ATA/133 controller to work...

Discussion in 'General Hardware' started by Kuja, Jul 23, 2002.

  1. Kuja

    Kuja OSNN Addict

    Messages:
    163
    Its the Promise Ultra ATA/133 Controller. I just bought it today, along with a 80gb/Ata133 Maxtor Drive. I tried installing XP, it works the first time it boots up, then when i restart XP it hangs at the boot screen, and the blue line just keep moving, as if XP is doing something, but it never finish's booting. This is really starting to piss me off... any help would be appreciated... thx in advance.
     
  2. dozer10

    dozer10 Guest

    Maybe boot sequence..a BIOS settings. Maybe leave HD attached to an on board IDE, then install the promise card, mess with BIOS settings again. These cards show as SCSI devices in device manager. Shaun
     
  3. Kuja

    Kuja OSNN Addict

    Messages:
    163
    Tried changing the boot sequence, didnt do anything.... hmm. My mobo is a Gigabyte 7ZM, if anyone can help me with that...... :S
     
  4. jonocainuk

    jonocainuk Guest

    did you manage to fix the problem by any chance?
    i have problems - also with a promise controller card :/

    winME/2K both install perfectly and run fine.

    WinXP has problems :/
     
  5. stuy_b

    stuy_b Guest

    When you install the PromiseTX2 Ultra card it will takeover IRQ15 your onboard secondary controller. In the BIOS disable your secondary onboard controller, ensure the auto detect in your motherboard BIOS has the secondary IDE controller DISABLED or set to NONE...not AUTO.

    You DO have to use the controller software supplied on disk, press F6 as WindowsXP is installing.. it asks for 3rd party devices.

    Also try putting the card in your last PCI slot.. NOT slot1.

    Hope this helps.. I have the card and its working perfect 1st time.

    Stuy_b
     
  6. jonocainuk

    jonocainuk Guest

    right... if i change the IRQ for a certain PCI slot in the BIOS, will that help change it from IRQ 15 so I can have both primary and secondary sockets in use?
    I can put the DVDROM on one and the CDRW on the other then - like I used to in Win2k.

    I will try that though - thanks :D
     
  7. stuy_b

    stuy_b Guest

    No that wont work.. sorry dude, :)
     
  8. jonocainuk

    jonocainuk Guest

  9. Aarow

    Aarow Guest

    In the BIOS disable your secondary onboard controller?????
    why??? i have a promise controller and have had no problems. And i can use all ide slots to there max. just make sure all hard drives are master on promise card not master/slave like on normal ide slot. works for me.
     
  10. stuy_b

    stuy_b Guest

    how?

    the promise card takes the IRQ15 allocation (your onboard 2nd IDE channels).

    So if the motherboard has IRQ14 with two devices, your prmosie card has two devices (now using IRQ15).... how the hell do you still use your onboard 2nd channel, if the IRQ is used by promise card???????????!!!!!!!!!!!1

    Believe me Ive tried!!.. yes the 2nd IDE channel from motherboard works.. but at its lowest speed. I did a test u c,

    I had DVD-ROM master on motherboardIDE1 as master, CDRW on motherboard IDE2 as master. PromiseTX2 with two ATA133 Harddisks, both masters. The end result?... CDRW drive on 2nd motherboard IDE port wouldnt go above PIO4 when its suppost to be ATA33. So I disabled motherboard IDE2 completely.. and had CDRW as slave to DVD-ROM.. perfect both were ATA33..
     
  11. jonocainuk

    jonocainuk Guest

    in my case, it wouldnt get past setting the partitions in WindowsXP installation. I'd create the partitions and WinXP Setup would reply with "no valid Windows XP partitions found on your system" and asks me if I want to create one now. So I choose Yes and it takes me back to the partition screen and looking at me is a screen with a C drive of 11gb and a D drive of ~18gb. So I choose the C drive AGAIN and AGAIN it tells me there is no valid partition on the drive.

    I take the promise ultraTX2/100 card out and plug the hdd into primary controller on mobo with DVD and CDRW on secondary controller (as master/slave respectively) and the problem is solved.

    When I get home, I'm gonna give that a go (disabling the secondary controller on the mobo). Wouldnt that help with system resources a bit too? I notice since me mum got a new IDE burner, and we had to enable the secondary controller (her old 2x burner was a SCSI - she still has a 40x plextor SCSI cdrom), her pc doesnt seem quite so nippy - if I mention its only a Celeron 433 w/ 384mb RAM, ppl will say its not quick enough, but it was rapid as f**k with the secondary controller disabled.
     
  12. stuy_b

    stuy_b Guest

    Make sure you press F6, as soon as you see the message (when installing XP from CD) on the blue screens, this will let you load the Promise IDE controller driver.. WITHOUT THIS XP WONT recognise any partitions or the drives....DO NOT use the driver XP offers (even if it says its newer)... all taken from Pomise TX2 ATA133 manual.

    Then once windows is installing say YES to using drivers (it asks you cos they are not dititally signed)
     
  13. jonocainuk

    jonocainuk Guest

    i only have win2k drivers for the card - they're the newest I have.

    promise replied to an email I sent them a while ago - when I was first on WinXP and they told me that WinXP had drivers in the OS and they were not releasing any specially. Do you think I would have to l33ch through cab files etc to get the drivers I need to make a manufacturer disk which I can use on F6?

    it will let me use the win2k drivers, but i get the same error. could that just be down to it using the same irq as secondary controller on the mobo? perhaps its trying to find the hdd on the 2ndary controller rather than the promise card?
     
  14. jonocainuk

    jonocainuk Guest

    oh and i also only have an ata100 card :(
    i only got it a few months before getting winXP and its out of date already :/
     
  15. Kuja

    Kuja OSNN Addict

    Messages:
    163
    I never did fix it, so I just returned it.... hehe. Kept the 2 80's, and thats it for now. Until i get a new computer with RAID, or ATA133, they'll have to stay at ATA66.
     
  16. jonocainuk

    jonocainuk Guest

    i fixed my problem with the ata100 card. just disabled secondary pci controller on the board. i also checked the promise site (just incase) and OMG!! they made some new drivers lol - finally!!

    Anyways... jobs sorted now and its workin alright :)
     
  17. dave holbon

    dave holbon Moderator

    Messages:
    1,014
    Location:
    London England
    I was unaware that XP supported ATA 133 even with device drivers (everything else being correct like the cable etc) and was told that it might be included with XP service pack 1. This means that whilst the promise card might transfer at this rate (from card to drive) it won't between the operating system and the card. This could cause problems with the NT file system which uses transactions to write to the drive.

    Mind you I could be wrong?
     
  18. jonocainuk

    jonocainuk Guest

    Ive noticed in some cases that I woulda gotten faster xfer rates if I was runnin the udma33 on the mobo, but ive stuck with the promise card cuz they're either gonna give us new drivers for it which ties in better with the OS, or the SP1 will sort it out somehow :)