Cant activate DMA-Mode for DVD

Discussion in 'General Hardware' started by Richy, Jan 20, 2002.

  1. Richy

    Richy Guest

    i cant activate the DMA for my DVD (Pioneer 105SZ), i set it in the control panel (sec.contro./slave : to "DMA if Available", but it shows alwys -> PIO !)

    where is the problem ? without the dma - mode i cant look DVDs with right speed (0.9x of the DVD-speed)

    thx
     
  2. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Go to Control Panel> System> 'hardware' tab> 'device manager' button> expand 'IDE ATA/ATAPI controllers' branch. You need to know which channel (primary or secondary) your dvd player is on, right click on the appropriate channel> properties> 'advanced settings' tab. You can select 'DMA if available' there.
     
  3. Richy

    Richy Guest

    i did it like that !!!!!!!!!!!!!!

    but it looks like that : ->> DMA if available
    ->> PIO-Mode

    i set it on DMA, but xp use the PIO - Mode !!!!!

    whats the prob ???
     
  4. Lonman

    Lonman Bleh!

    Messages:
    2,642
    I would have to guess your drive won't support DMA mode for some reason or other. Go to Pioneer and see if they have any firmware updates for it. If that doesn't fix it, try updating your m/b bios.
     
  5. Richy

    Richy Guest

    found a solution, but .... look urself

    first my config was like that :
    ide1 -> 1 HDisk UDMA 100 (dma-mode 5 in xp)
    ide2 -> Master 1 HDisk UDMA 66 (dma-mode 4 in xp)
    Slave 1 DVD UDMA 33 -> but in xp only pio-mode !!

    now: ide1 -> Master HDISK UDMA 100
    -> Slave DVD UDMA 33
    ide2 -> single HDisk UDMA 66

    but now xp shows for the dvd -> DMA-Mode 2 !!! an it works good for dvd-films, no breaks etc.

    but why it doenst work on the sec.ide controller ???

    hm, bullsh...
     
  6. Lonman

    Lonman Bleh!

    Messages:
    2,642
    My guess is it's some kind of glitch with the chipset IDE drivers. Glad to hear you got it working.
     
  7. Richy

    Richy Guest

    yeap, i also think so ..... now i changed the ide-chanels , so i can use the fast drive as a single on ide2 for the better speed an the dvd as slave on ide1 ... and it works .... but its a little silly (i have the latest via chipset drivers ... what can i do)

    mhm, dont know but if it works i do it like that.

    gn8
     
  8. Lonman

    Lonman Bleh!

    Messages:
    2,642
    VIA has had a bear of time just getting there drivers to work at all. Give them more time is all I can suggest, they're bound to accidently get it right one of these days.
     
  9. mavis

    mavis Guest

    here's a solution that worked well for me...


    Here is the original post.

    Hope this helps, it worked for me! Got DMA back :)

    mavis
     
  10. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    This worked for me also!

    I had one drive that was PIO, and although it wasn't a problem i done the reg hack and now it DMA cool!
     
  11. Richy

    Richy Guest

    yes !!!!

    it works, but now i dont have the tab "advanced options" for the sec.chan. ......
    (until i update the drivers next time, i think)
     
  12. pinkshark

    pinkshark Guest

  13. morpheus2k

    morpheus2k Guest

    I know this is a bit late...

    Check you BIOS - I couldn't even get an offer for DMA, until I checked in my BIOS and saw that the IDE Secondary Slave (were my DVD drive is), had UDMA "disabled" - so I enabled it and now it works great.