Boot.ini Help

Discussion in 'Windows Desktop Systems' started by Trizum, Feb 17, 2004.

  1. Trizum

    Trizum OSNN One Post Wonder

    Messages:
    9
    I was messing around with TFT Soft's new Style XP and the boot scree and stuff, and somehow my boot.ini got deleted and now when I start my computer it tells me my boot.ini was not found and it is going to boot from C:\Windows\ it boots fine, but there is a delay because it is looking for the boot.ini.

    I am using Windows XP Pro, is the boot.ini pretty consistent from PC to PC and could I just get someone's?

    Or do I need to rebuild my own? If so how do I do that?

    Thanks a lot in advance,
    Trizum :D
     
  2. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    Create a boot.ini file in C:\ with the following contents:

    Code:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    
    It should work, assuming Windows is installed on the first partition of the drive and is located in C:\WINDOWS
     
  3. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Check C:\Windows\pss a backup is placed there, although netryder's should work fine.
     
  4. Trizum

    Trizum OSNN One Post Wonder

    Messages:
    9
    This one didn't work, but the first one did!

    Thanks!
     
  5. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    Similar issue except I have my OS on another lettered drive :) which is the primary partitian of course. So do I change the partition # to the primary OS location, which is my #4 primary partitioned drive, or do I leave it 1. Also I did not have a backup boot.INI in my Windows\pss. (This screw up is all because I installed beta Longhorn 4051 and after I UN-installed and rebooted I continued to get Longhorn OS Professional and Original options in my boot.INI. So every time I reboot I have to manually move my arrow button to stop the auto-reboot into the Longhorn OS which doesn't exist anymore and option to XP professional.. :( confusing)

    --So my question "how can I got my pc to boot automatically into my XP Professional OS if it isn't located in C:\ drive. Its in G:\ drive (Primary)
     
  6. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    If you can boot into XP by selecting the XP option, the boot.ini is fine. All you need to do is edit it and remove the entry for Longhorn in there, and then copy the path to XP under the "[operating systems]" section to the [defaults] section. It should end up looking like what I posted a few posts above, except that your partition number would probably be 3 (it starts with 0, by the way) Don't change anything about the XP entry, since that's working properly already.
    Another option is to boot into the Recovery Console, and use the FIXMBR command. More info in this thread:
    http://www.ntfs.org/forum/showthread.php?t=384
     
  7. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
  8. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    Not a problem :)