Bios Flash Question

Discussion in 'General Hardware' started by bmxjt, Apr 11, 2002.

  1. bmxjt

    bmxjt Guest

    I am trying to flash my bios to the latest version. Here are some of the Steps listed from the site where I got the flash version on. I did everything and followed step by step but it didnt even work. It never started correctly.

    Step 3. Insert a floppy disk into drive A. Format the floppy disk and make it bootable. (Make sure the floppy does not have a config.sys or autoexec.bat file on it)

    Step 4. Extract the contents of the .ZIP file you downloaded, onto the bootable floppy disk that you created during Step 3.

    Step 5. Place the bootable floppy containing the BIOS files into drive a: of the system that you want to upgrade and boot the system. (Make sure the BIOS setting has drive A has a primary boot check.)

    Step 6. At the command prompt type Flash.bat


    OK, In step 3, How do I make it bootable? I formatted in XP and did it as a MSDOS start disk. I then removed the config.sys and autoexec.bat files like it says. I then added the files from the .zip.

    Step 6 - I typed it and it said Bad File command. There isn't a Flash.bat file on my floppy. It wasn't included with the bios .zip file.

    Any suggestions? Is there maybe a different site that has Bios upgrades for many different Mobo's? My mobo isnt supported by the manufacturer anymore. Its a kr632. I want to flash the bios so I can get it to read my 40 gig hd and install a 533 celery processor.

    thanks!
     
  2. Lonman

    Lonman Bleh!

    Messages:
    2,642
    What files are in the zip file you extracted from? If there's a :confused:.bat of any kind, right click on it and select 'edit.' Post what you see.

    You did boot to the floppy right? I mean you got to the point you typed 'flash.bat' so I can only assume the floppy is bootable.
     
  3. SessedOut

    SessedOut Guest

    hey man, try this site http://www.wimsbios.com/

    i recently had to flash my bios also to get my 60gb drive to get recognized. basically, i just got the flash utility from my mobo maker's website and the bios file. mine was a .exe file, so at the command prompt (bootup with a floppy) i just type flshaward.exe or something pretty similar. then it asked what bios file to use, i typed in the location on a:\ and everything was fine.

    but check that page out, it helped me a lot. also remember to backup your old bios just in case (the flash program should do this for you).
     
  4. G-Money

    G-Money Big Air

    Messages:
    569
    Location:
    Springfield Mo
    Just flashed my bios today...... All i did was,


    1. Made sure that my computer tried to boot from floppy first. You can change this in the bios.

    2. I unziped the file and placed it on a blank floppy (This will be a .bin file ). You will also need a program called AWDFLASH.EXE on the floppy as well.

    3. Ok the funny part. All I did was put in my old 98se boot disk and had it start up that way. Yes it worked. :p

    4. Now then, take on the boot disk and put in the other disk. Type AWDFLASH. Then the progy with start. Type in the name of the .bin file. Mine was " kvxa2ba3.bin " You must inclued the .bin in the name press enter. It then will ask if you want to backup your current bios. Yes would be a good idea.

    Hope this helps....

    :cool:
     
  5. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    Sorry just had to add this in case there is any confusion to the original question asker...AWDFLASH is not required unless that is the program that needs to be used to flash your bios...I believe AWD flash is for AWARD bios's...if your comp has a different bios such as pheonix, AMI, or a few other possibles out there you would need to use the relevant flash utility.
     
  6. bmxjt

    bmxjt Guest

    I did indeed try to boot from the floppy first.

    These are the files that were included in the .zip file

    Kr632a10.rom and FLASH819.EXE


    no .bin file or .bat file
     
  7. Lonman

    Lonman Bleh!

    Messages:
    2,642
    I think the flash819.exe is either your flashing utiltiy (similar to awdflash.exe, etc. Or it's a self extracting archive file). Do me a favor and post a link to where you downloaded your bios upadate, with an exact reference to what you have. I'll download it and see what's up.

    One more question, you 'tried' to boot to your floppy, or you did boot to your floppy? If you don't have a bootable floppy, make a new one from another diskette (the description you gave is the correct one for doing this).
     
  8. bmxjt

    bmxjt Guest

    i made a bootable floppy AND tried booting from it. Everything was fine up until I typed in flash.bat. And of course it cant find a non-existing file.

    the link is http://www.bcmcom.com/tech/kr632/kr632bios.asp
    and its the A10 update
     
  9. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Ok, the flash819.exe is your flash utility program - what this does it takes the information from the Kr632a10.rom file and writes it to your bios.

    Go ahead and boot to the floppy again and type in flash819.exe - this should correctly identify whether or not your board will support this procedure. Write down 'Kr632a10.rom' in case you need to enter the file name manually. Point the flash utility to that file and it should pick it right up and do it's thing. I believe you'll also be asked if you want to back-up your old bios - good idea - just save it to the floppy.

    You already know all the other steps from the link you gave me... It would be good to print those out and follow them to the letter.

    Final note. Don't be disappointed if this doesn't produce the desired results for you... that's a pretty old board you have there. I once flashed an old PII board to support a PIII 500 CPU - didn't work (but the old cpu still did so I didn't actually lose ground - just couldn't upgrade).

    Good luck and let us know how it goes.
     
  10. bmxjt

    bmxjt Guest

    Thanks, I will try it out and report my results.
     
  11. bmxjt

    bmxjt Guest

    Wow, that was very painless and quick too. I hope I am able to update my processor now AND maybe my bios will recognize my 40 gig HD
     
  12. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Very cool - glad it went smooth for you. Good luck with the upgrade. ;)
     
  13. bmxjt

    bmxjt Guest

    thanks. doesnt appear to recognize my 40 gig HD tho. only 31 gigs. ugh, but thats a entire different post already here. :)