autorun CD in XP?

Discussion in 'Windows Desktop Systems' started by electrolite, Jan 14, 2004.

  1. electrolite

    electrolite OSNN One Post Wonder

    Messages:
    2
    The "autorun" function of my CD drive seems to be disabled... when I put a CD in, nothing happens. How do you re-enable this?
     
  2. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    1) Click Start>Run>GPEDIT.MSC
    2) Go to Computer Configuration>Administrative Templates>System.
    3) "Turn autoplay off" is the setting you want to change.

    For XP Home (which does not include gpedit.msc), follow these instructions:
    http://support.microsoft.com/?kbid=330135

    Hope that helps. :)
     
  3. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    right click on the drive in explorer, select properties, go to the autoplay tab
     
  4. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    "Select a content type, then choose an action for windows to perform automatically when that type is used for this devise" currently mine says Music files but it also has options for pictures, video files, mixed content, music CD, and DVD movie. What should it be on so when you place media in the drive it will autoplay, autorun in any format. I'm having this same problem on my daughters PC and I tried the edit in the registry setting "My computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom\Auto" and changed the value data to 1" and this didn't work. This one does look promising. Any possibility this could happen "if" the primary and secondary IDE cables get switched around after installing hardware on CD/DVD drives and hard drive. Wouldn't they then be switched around in the BIOS settings.
    :confused:
     
  5. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    Tried all the above and still not starting up after putting CD in drive. When I click on the CD-RW drive Icon it starts right up. ?
     
  6. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,928
    Location:
    Seattle
    If you have not done so try changing each entry in drop down box of autoplay tab to default (click restore defaults).
    Each one has it's own entry and the one you need may be set to "take no action".
     
  7. Jimbo

    Jimbo OSNN Junior Addict

    Messages:
    23
    Check your Services and make sure Shell Hardware Detection is set to Automatic.
     
  8. i say go with what netryder said or u can use autofix i think it might help too
     
  9. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,589
    Location:
    Copenhagen, Denmark
    There was some registry entry where you had to change some value, but I imagine the above suggestions will cover that!

    (I think the Tweak-XP application broke mine, evil!)
     
  10. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    I say stick a weasel in it, see what happens
     
  11. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,589
    Location:
    Copenhagen, Denmark
    can't go wrong with that really.
     
  12. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    Maybe something like this ?

    [​IMG]


    I'll give a a go Khayman and see what happens. :)

    Thanks for all your feedback guys. I'll try a couple of these suggestions and report back.