Atapi.sys problem

Discussion in 'Windows Desktop Systems' started by one.123, Jul 18, 2005.

  1. one.123

    one.123 -0-;;

    Messages:
    231
    i made a thread awhile ago explaining my problem with stop errors..well i have more information on the error that i still have.

    it is a stop error "driver_irql_not_less_or_equal (0x000000D1) and it either shows no driver or shows atapi.sys

    i have a 120gb as my master, and a 160 as slave. i heard that you need an updated atapi.sys to run hdd's that are over 137gb. but i havent' had this problem until i moved to pci-express. i also heard that this kind of stop error could be associated with memory..i did run memtest+ overnight and it passed all of the tests, around eight times i think. i also reformatted already. the bsod usually appears when i run a game, it doesn't happen very often when im just using firefox or other applications, but it does happen. so does anyone know what could be causing this problem?

    also what is the difference between raid, sata, and ide. would switching from ide to sata or raid solve this problem?
     
  2. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    What operating system do you run and if XP do u have SP2 installed. I think they fixed the limit in SP2.
     
  3. one.123

    one.123 -0-;;

    Messages:
    231
    yea i have sp2. and i just read something about updated atapi.sys in sp2
     
  4. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

  5. one.123

    one.123 -0-;;

    Messages:
    231
    so does SATA have any advantages over IDE? and can any hdd use SATA?
     
  6. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Well SATA is a bit faster, you either need an adapter to use an IDE drive but there is zero advantages to that.

    The best way would be to buy SATA drives from now on and slowly convert. Remember that unlike IDE its only 1 drive per port. So it you have 2 SATA ports on the computer then you can only have 2 SATA drives (unless you buy a PCI addon card).

    question, have you installed the motherboard's drivers? Like the chipset and such?
     
  7. one.123

    one.123 -0-;;

    Messages:
    231
    yes updated all drivers, graphics card, nforce drivers, except for the nvidia ide manager, which i didn't install because it gave me stop errors as well, and when i deleted them it started giving atapi.sys with the stop errors. so im guessing its a harddrive compatibility issue with the new mobo and graphics card. anything about certain hdd's not working with pci-express? so if i use SATA, it won't use the atapi.sys driver or will it?
     
  8. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Im not sure about the ATAPTI.sys and SATA.

    Your move to PCI-Express, this was a new motherboard exchange correct? If so did you format and reinstall windows (format not "Repair")
     
  9. one.123

    one.123 -0-;;

    Messages:
    231
    yea i had to, windows wouldn't load for me
     
  10. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Im wondering if it could be related to the IDE drivers you didnt install. Are these off the CD or updated off the manufacturer's site?
     
  11. one.123

    one.123 -0-;;

    Messages:
    231
    the ide drivers i didn't install were the nvidia ide manager drivers. they came with the cd and are offered through the nvidia site. the first time i installed windows, i installed the drivers. but then i got stop errors that were the same as the one i am having now only that atapi.sys was replaced with nvatabus.sys i believe.
     
  12. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    I quickly re-skimmed through the previuos posts, you didnt mention the board your using.
     
  13. one.123

    one.123 -0-;;

    Messages:
    231
    its the BFG nforce4 amd 939socket board
     
  14. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    never heard of BFG (I stay away from unknown types). Since the site says to use the drivers from Nvidia.com Im not sure what else to suggest.
     
  15. one.123

    one.123 -0-;;

    Messages:
    231
    hmm someone recommended that i call mircrosoft tech support...would this be a good idea? and do you know wehre i could find the number to reach them..i went to their site and all i could find was a number that was around 200$ per call..is this the only option?
     
  16. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    IF your copy is legit. Even at that Im not sure how much help that would be since Ive never called and wouldnt want to.
     
  17. one.123

    one.123 -0-;;

    Messages:
    231
    hmm just saw something weird..i turned on my comp and as windows loaded i saw my fan on my cpu stop...but it turned on again right when it came to a complete stop..so now im wondering maybe some of my hardware is busted? i did move the hardware seperatley when i moved..so maybe something got messed up?
     
  18. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Is this the fan than came with the CPU or a third party fan? and is it plugged into the motherboard or thru a power supply plug via an adapter?
     
  19. one.123

    one.123 -0-;;

    Messages:
    231
    its the fan and heatsink that came with the cpu...and its connected through the motherboard
     
  20. one.123

    one.123 -0-;;

    Messages:
    231
    hmm anyone else have any ideas on what the problem might be?