ACPI disabled,HELP!

Discussion in 'Windows Desktop Systems' started by Kafros, Jan 15, 2003.

  1. Kafros

    Kafros Guest

    Hi,I had irq problems with my pc so a friend suggested that in order to free some irq's i should disable ACPI so that everything will get its own irq(or so i thought :()and everything will be ok.
    But after doing that I am experiencing new problems.Mouse and keyboard keep freezing up at random and I need to reboot a couple of times per hour.I Know that i should have posted here in the first place for help but I am asking for help now.Is there a chance that having ACPI disabled is not the cause for my problem?Any help appreciated.

    PS: I got a logitech keyboard without I-touch installed and a mircosoft optical mouse with Intellipoint installed.
  2. allan

    allan Guest

    Well, first thing is I don't know what your original problems were - what is it you were trying to fix?

    Second, XP shares IRQ's by design and as a rule it does a very nice job of doing so. Installing Disabling ACPI is rarely a good idea (and you can tell your friend that). Best thing to do is re-enable ACPI and tell us what it is you are having a problem with.
  3. Kafros

    Kafros Guest

    Allan thanx for the reply.My original problem was that I was using the onboard sound of my board CMI8738 and it was using the same irq as Intel(r) 82801BA/BAM USB Universal Host Controller -2442 and Intel(r) 82801BA/BAM USB Universal Host Controller -2444.That resulted in crappy sound,especially when I connected to the internet with my usb adsl modem.I was trying to figure out how to change the irq for CMI8738 when a friend suggested I should try disabling ACPI.The problem with the sound is fixed now,but I am having the mouse and keyboard problems.CMI8738 now shares the same irq as my Radeon card.I haven't enabled ACPI yet because I am hoping that this mouse keyboard thing will be solved somehow.
  4. allan

    allan Guest

    Well, I'm not a big fan of usb modems. If your ISP offers an ethernet option I'd strongly suggest that. Same goes for onboard sound - I've seen more problems / conflicts with onboard sound chips than you would believe. Some can be fixed with bios updates, but mostly I and the folks I know suggest going to a sound card and disabling the onboard sound (yeah, I know - just letting you know what we've seen, that's all).

    I do seem to remember something about the Radeon and a similar problem - I may be mistaken - but I'll try to do a little scouting around and see what I can come up with.

    I recognize this isn't what you were looking to hear and it's certainly possible someone else will have some other thoughts - likely better thoughts ;) Still, that's what I know.
  5. Kafros

    Kafros Guest

    Thanx again for your reply allan,I switched back to ACPI enabled now and thankfully CMI8738 has now got it's own irq and the sound is ok,even when I connect to the net.As for your other advice I am thinking of buying an Audigy card and I found a friend selling an ethernet modem so I guess I'll be ok from now on.
    Thanx again for the help.
  6. Dolph29

    Dolph29 Guest

    ACPI Info

    Hey All,
    What's new? Kafros, I just wanted to let you know...
    There is way to disable the ACPI setting, which is useful in solving some hardware conflicts & power management issues. Doing this is also supposed to increase your system's performance (esp. when using graphic/memory intense apps.)
    I'm attaching a file with the procedures for doing this, which also gives more details about ACPI & performance.